aboutsummaryrefslogtreecommitdiff
path: root/math/py-gimmik
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-20 21:48:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-20 21:48:56 +0000
commit57abffa30e291e4864b86e5cb4281ad2f1ccae70 (patch)
tree0878676eca00daf88b3de5bc16133cb6dbc0997b /math/py-gimmik
parent63c5825f95bed656a20f07bb296e863eb518003b (diff)
downloadports-57abffa30e291e4864b86e5cb4281ad2f1ccae70.tar.gz
ports-57abffa30e291e4864b86e5cb4281ad2f1ccae70.zip
New port: math/py-gimmik: Generator of Matrix Multiplication Kernels
Notes
Notes: svn path=/head/; revision=480219
Diffstat (limited to 'math/py-gimmik')
-rw-r--r--math/py-gimmik/Makefile21
-rw-r--r--math/py-gimmik/distinfo3
-rw-r--r--math/py-gimmik/pkg-descr5
3 files changed, 29 insertions, 0 deletions
diff --git a/math/py-gimmik/Makefile b/math/py-gimmik/Makefile
new file mode 100644
index 000000000000..9c675fdf3b32
--- /dev/null
+++ b/math/py-gimmik/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= gimmik
+DISTVERSION= 2.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Generator of Matrix Multiplication Kernels
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}
+
+USES= python:3.3+
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-gimmik/distinfo b/math/py-gimmik/distinfo
new file mode 100644
index 000000000000..02e1cc2e7185
--- /dev/null
+++ b/math/py-gimmik/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537478754
+SHA256 (gimmik-2.1.tar.gz) = 36ec13aff705e787b856ae236211d1826ceaa4b22d52d4d98ff72642bb4021a3
+SIZE (gimmik-2.1.tar.gz) = 3503
diff --git a/math/py-gimmik/pkg-descr b/math/py-gimmik/pkg-descr
new file mode 100644
index 000000000000..9ef1522318aa
--- /dev/null
+++ b/math/py-gimmik/pkg-descr
@@ -0,0 +1,5 @@
+Generator of Matrix Multiplication Kernels (GiMMiK) is a tool for generation of
+high performance matrix multiplication kernel code for various accelerator
+platforms. Currently CUDA and OpenCL are the only supported platforms.
+
+WWW: https://github.com/vincentlab/GiMMiK