aboutsummaryrefslogtreecommitdiff
path: root/math/py-pyhull/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-12-25 09:20:38 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-12-25 09:20:38 +0000
commit5e279ec3d32423c4fc605bb6c4d0ac1e95682c25 (patch)
tree669ebda902227609dff07b873a823eb8f8b385c8 /math/py-pyhull/Makefile
parente1e3fe2e3012e5a9c1713a364e7135c58268fc34 (diff)
downloadports-5e279ec3d32423c4fc605bb6c4d0ac1e95682c25.tar.gz
ports-5e279ec3d32423c4fc605bb6c4d0ac1e95682c25.zip
Add py-pyhull 1.5.6, computation of convex hull, Delaunay triangulation
and Voronoi diagram. PR: 205593 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=404409
Diffstat (limited to 'math/py-pyhull/Makefile')
-rw-r--r--math/py-pyhull/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/py-pyhull/Makefile b/math/py-pyhull/Makefile
new file mode 100644
index 000000000000..a00972a029da
--- /dev/null
+++ b/math/py-pyhull/Makefile
@@ -0,0 +1,24 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pyhull
+PORTVERSION= 1.5.6
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Computation of convex hull, Delaunay triangulation and Voronoi diagram
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pyhull/_pyhull.so
+
+.include <bsd.port.mk>