aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@utahime.org>2021-05-15 06:50:22 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-05-15 07:14:04 +0000
commit9671981826f7ef8b1e7fb0a430ee24d4a1f0acf2 (patch)
treefe4be6c86d5ebad1e08ad79d5ed6ba427147cd8e /math
parent4032ece1e981d7f4f214aeebb25dfcf22a625d2b (diff)
downloadports-9671981826f7ef8b1e7fb0a430ee24d4a1f0acf2.tar.gz
ports-9671981826f7ef8b1e7fb0a430ee24d4a1f0acf2.zip
*: Remove unnecessary 'port' argument from USES=readline
PR: 248459 Exp-run by: antoine
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile2
-rw-r--r--math/asymptote/Makefile2
-rw-r--r--math/cvc4/Makefile2
-rw-r--r--math/eukleides/Makefile2
-rw-r--r--math/libqalculate/Makefile2
-rw-r--r--math/units/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 2cda68013594..8ca604cb38bc 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= gmake:devel/gmake
# - Create a meta-port for the recommended packages
USES= compiler:c++11-lang gmake iconv libtool localbase pathfix perl5 \
- readline:port
+ readline
USE_LDCONFIG= ${PREFIX}/lib/R/lib
USE_PERL5= build
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 274d61913e5d..74947c18085f 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -70,7 +70,7 @@ OFFSCREEN_DESC= Enable offscreen rendering using OSMesa library
OFFSCREEN_LIB_DEPENDS= libOSMesa.so:graphics/libosmesa
READLINE_CONFIGURE_ENABLE= readline
-READLINE_USES= readline:port
+READLINE_USES= readline
TEST_TARGET= test
TEST_WRKSRC= ${WRKSRC}/tests
diff --git a/math/cvc4/Makefile b/math/cvc4/Makefile
index 45f716f4baa4..47f620bb2e02 100644
--- a/math/cvc4/Makefile
+++ b/math/cvc4/Makefile
@@ -60,7 +60,7 @@ PYTHON_CMAKE_BOOL= BUILD_BINDINGS_PYTHON USE_PYTHON3
PYTHON_BUILD_DEPENDS= swig:devel/swig
READLINE_CMAKE_BOOL= USE_READLINE
-READLINE_USES= readline:port
+READLINE_USES= readline
GMP_CMAKE_BOOL= ENABLE_PORTFOLIO
GMP_CMAKE_ON= -DENABLE_DUMPING=OFF
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index 36d93b77c2d8..653c99786f78 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= pstoedit:graphics/pstoedit \
getopt>=0:misc/getopt
-USES= bison gettext iconv gmake readline:port tar:bzip2
+USES= bison gettext iconv gmake readline tar:bzip2
USE_TEX= latex
INSTALL_TARGET= install PREFIX=${STAGEDIR}${PREFIX}
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index a160134d1beb..5e1c5094c96e 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libicuuc.so:devel/icu \
libmpfr.so:math/mpfr
USES= compiler:c++14-lang gettext gmake gnome iconv libtool \
- localbase ncurses pathfix pkgconfig readline:port
+ localbase ncurses pathfix pkgconfig readline
USE_GNOME= intltool libxml2
USE_LDCONFIG= yes
diff --git a/math/units/Makefile b/math/units/Makefile
index c16302cdfbad..8914a816431f 100644
--- a/math/units/Makefile
+++ b/math/units/Makefile
@@ -19,7 +19,7 @@ INFO= units
OPTIONS_DEFINE= READLINE
OPTIONS_DEFAULT= READLINE
-READLINE_USES= readline:port
+READLINE_USES= readline
post-patch:
@${REINPLACE_CMD} -e \