aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-16 15:47:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-16 16:24:48 +0000
commitd6119b94a3dad8233f2da6dee1c957d205ad69ee (patch)
tree66558dde75884a9e23c846ed007748887afeaf42 /math
parentee6588e8e25fa4fe15658d46de33c8755d577ec2 (diff)
downloadports-d6119b94a3dad8233f2da6dee1c957d205ad69ee.tar.gz
ports-d6119b94a3dad8233f2da6dee1c957d205ad69ee.zip
math/kamis: Broken on armv6, armv7, riscv64
Reported by: fallout
Diffstat (limited to 'math')
-rw-r--r--math/kamis/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/math/kamis/Makefile b/math/kamis/Makefile
index 2794cab7f0bc..2185a844f918 100644
--- a/math/kamis/Makefile
+++ b/math/kamis/Makefile
@@ -10,6 +10,9 @@ COMMENT= Maximum independent sets and vertex covers of large sparse graphs
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_armv6= fatal error: 'omp.h' file not found
+BROKEN_armv7= fatal error: 'omp.h' file not found
+
USES= cmake
USE_LDCONFIG= yes
@@ -22,4 +25,10 @@ PLIST_FILES= bin/graphchecker \
bin/redumis \
bin/sort_adjacencies
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1301000
+BROKEN_riscv64= fatal error: 'omp.h' file not found
+.endif
+
+.include <bsd.port.post.mk>