aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-23 16:13:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-23 16:14:05 +0000
commite7105c1ff88e2ef8ecc070174516e46ce34c3bea (patch)
tree3ce0277e34e134fd7e43caead1bc10b94e51197c /math
parentc16c251de9c90431213f24be8c26ae33e50254ca (diff)
downloadports-e7105c1ff88e2ef8ecc070174516e46ce34c3bea.tar.gz
ports-e7105c1ff88e2ef8ecc070174516e46ce34c3bea.zip
math/faiss: Broken on systems where OpenMP isn't enabled
Reported by: fallout (cherry picked from commit c52e62fa836103e2da624c6ea1d90c32ea69fde1)
Diffstat (limited to 'math')
-rw-r--r--math/faiss/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/faiss/Makefile b/math/faiss/Makefile
index c1aede497daa..9fdcc065a48a 100644
--- a/math/faiss/Makefile
+++ b/math/faiss/Makefile
@@ -9,6 +9,10 @@ COMMENT= Library for efficient similarity search & clustering of dense vectors
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+.if !exists(/usr/include/omp.h)
+BROKEN= requires OpenMP support that is missing on this architecture
+.endif
+
BUILD_DEPENDS= openblas>0:math/openblas # faiss links with libopenblasp-rN.N.N.so (installed by default only on amd64,i386), so use non-filename-specific DEPENDS commands
RUN_DEPENDS= openblas>0:math/openblas