aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/faiss/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/faiss/Makefile b/math/faiss/Makefile
index c1aede497daa..9fdcc065a48a 100644
--- a/math/faiss/Makefile
+++ b/math/faiss/Makefile
@@ -9,6 +9,10 @@ COMMENT= Library for efficient similarity search & clustering of dense vectors
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+.if !exists(/usr/include/omp.h)
+BROKEN= requires OpenMP support that is missing on this architecture
+.endif
+
BUILD_DEPENDS= openblas>0:math/openblas # faiss links with libopenblasp-rN.N.N.so (installed by default only on amd64,i386), so use non-filename-specific DEPENDS commands
RUN_DEPENDS= openblas>0:math/openblas