aboutsummaryrefslogtreecommitdiff
path: root/multimedia/py-cec/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2016-08-11 15:13:34 +0000
committerKevin Lo <kevlo@FreeBSD.org>2016-08-11 15:13:34 +0000
commit7ae337bf48c31b61fef4aa667862b742ae4aba5d (patch)
treeb3fa7e11118fb896b59b43bf34aa4ea8df7882e5 /multimedia/py-cec/Makefile
parenteb4b5a41e14cdd1cc4fe10745a00986366577d09 (diff)
downloadports-7ae337bf48c31b61fef4aa667862b742ae4aba5d.tar.gz
ports-7ae337bf48c31b61fef4aa667862b742ae4aba5d.zip
Import py-cec 0.2.5
Python-cec allows you to control your TV, reciever and other CEC-compliant HDMI devices from a python script on a computer.
Notes
Notes: svn path=/head/; revision=420077
Diffstat (limited to 'multimedia/py-cec/Makefile')
-rw-r--r--multimedia/py-cec/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/multimedia/py-cec/Makefile b/multimedia/py-cec/Makefile
new file mode 100644
index 000000000000..f991c590671b
--- /dev/null
+++ b/multimedia/py-cec/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= cec
+PORTVERSION= 0.2.5
+CATEGORIES= multimedia python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Python bindings for libcec
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcec.so:multimedia/libcec
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+CPPFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>