aboutsummaryrefslogtreecommitdiff
path: root/net-im/libpurple
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2015-12-19 21:40:41 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2015-12-19 21:40:41 +0000
commited6278ec2ae12e4df46f4608db9bff8ce93b8860 (patch)
tree4ec57fc59865b5f649e7d0a3c928ecd001c4b323 /net-im/libpurple
parentc2624acd26e2b87e526695c33809ebadebd04319 (diff)
downloadports-ed6278ec2ae12e4df46f4608db9bff8ce93b8860.tar.gz
ports-ed6278ec2ae12e4df46f4608db9bff8ce93b8860.zip
Add support for building finch with port's ncurses.
PR: 205407
Notes
Notes: svn path=/head/; revision=404029
Diffstat (limited to 'net-im/libpurple')
-rw-r--r--net-im/libpurple/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 2def4cb4c144..c7dd47fb6be2 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -77,6 +77,8 @@ PLIST_SUB+= GTKUI="@comment not installed: "
.endif
.if defined(WITH_CONSOLEUI)
+OPTIONS_DEFINE+=NCURSES
+NCURSES_DESC= Build with ncurses from ports
PLIST_SUB+= CONSOLEUI=""
.else
PLIST_SUB+= CONSOLEUI="@comment not installed: "
@@ -97,6 +99,13 @@ CONFIGURE_ARGS+= --disable-tcl
PLIST_SUB+= TCL:="@comment not installed: "
.endif
+.if ${PORT_OPTIONS:MNCURSES}
+USES+= ncurses:port
+CONFIGURE_ARGS+=--with-ncurses-headers=${LOCALBASE}/include/ncurses/
+.else
+USES+= ncurses
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(PIDGIN_SLAVE)