aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-01-21 13:11:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-01-21 13:11:28 +0000
commitfbf834afa3edc2e26e289482a4ca9bd2e14e93ee (patch)
treefa2737a91e9c0ef094cab3b8a132e0e615f26e76 /net-mgmt/nagios-plugins
parent9b5d5f0f36da8ef5e1521d9bfd2e1ddffeae047c (diff)
downloadports-fbf834afa3edc2e26e289482a4ca9bd2e14e93ee.tar.gz
ports-fbf834afa3edc2e26e289482a4ca9bd2e14e93ee.zip
Fix check_dhcp.
PR: 196964 Submitted by: Rudolf Čejka Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=377599
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 88c657ae3c65..2b9a2b841ca5 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 2.0.3
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c b/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
new file mode 100644
index 000000000000..4ee277ab73c9
--- /dev/null
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
@@ -0,0 +1,12 @@
+--- plugins-root/check_dhcp.c.orig 2014-06-26 16:17:12 UTC
++++ plugins-root/check_dhcp.c
+@@ -326,7 +326,8 @@ int get_hardware_address(int sock,char *
+ #elif defined(__bsd__)
+ /* King 2004 see ACKNOWLEDGEMENTS */
+
+- int mib[6], len;
++ int mib[6];
++ size_t len;
+ char *buf;
+ unsigned char *ptr;
+ struct if_msghdr *ifm;