aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/p5-Net-BitTorrent-File
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-02-19 17:35:38 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-02-19 17:35:38 +0000
commita79321e3525bffe75942a776ff973cb10a80589b (patch)
tree16535c01fc54e3f7c1f0324f7a11d00f77c8303a /net-p2p/p5-Net-BitTorrent-File
parent3226f4727dd21229dfaca3d2bb8372e973a96714 (diff)
downloadports-a79321e3525bffe75942a776ff973cb10a80589b.tar.gz
ports-a79321e3525bffe75942a776ff973cb10a80589b.zip
- unbreak it on old perl
- fix plist
Notes
Notes: svn path=/head/; revision=156399
Diffstat (limited to 'net-p2p/p5-Net-BitTorrent-File')
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/Makefile18
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/pkg-plist8
2 files changed, 20 insertions, 6 deletions
diff --git a/net-p2p/p5-Net-BitTorrent-File/Makefile b/net-p2p/p5-Net-BitTorrent-File/Makefile
index 44891551fb44..eb227ab01b39 100644
--- a/net-p2p/p5-Net-BitTorrent-File/Makefile
+++ b/net-p2p/p5-Net-BitTorrent-File/Makefile
@@ -16,9 +16,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-fix
MAINTAINER= mor@WhiteLuna.com
COMMENT= Perl5 module for handles loading and saveing of .torrent file
-BUILD_DEPENDS= ${SITE_PERL}/Convert/Bencode.pm:${PORTSDIR}/converters/p5-Convert-Bencode \
+RUN_DEPENDS= ${SITE_PERL}/Convert/Bencode.pm:${PORTSDIR}/converters/p5-Convert-Bencode \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
WRKSRC= ${WRKDIR}/${DISTNAME:S/-fix//}
@@ -26,4 +27,15 @@ PERL_CONFIGURE= yes
MAN3= Net::BitTorrent::File.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${REINPLACE_CMD} -e '/warnings/d' ${WRKSRC}/lib/Net/BitTorrent/File.pm
+ ${FIND} ${WRKSRC} -name "*.bak" -delete
+
+post-configure:
+ ${PERL} -pi -e 's/-I\S+PERL\S+ //g if m{PERL_DL_NONLAZY}' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/p5-Net-BitTorrent-File/pkg-plist b/net-p2p/p5-Net-BitTorrent-File/pkg-plist
index 69dda328ced9..b6f6506fb383 100644
--- a/net-p2p/p5-Net-BitTorrent-File/pkg-plist
+++ b/net-p2p/p5-Net-BitTorrent-File/pkg-plist
@@ -1,5 +1,7 @@
-%%SITE_PERL%%/mach/auto/Net/BitTorrent/File/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/BitTorrent/File/.packlist
%%SITE_PERL%%/Net/BitTorrent/File.pm
-@dirrmtry %%SITE_PERL%%/mach/auto/Net/BitTorrent/File
-@dirrmtry %%SITE_PERL%%/mach/auto/Net/BitTorrent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/BitTorrent/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/BitTorrent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
@dirrmtry %%SITE_PERL%%/Net/BitTorrent
+@dirrmtry %%SITE_PERL%%/Net