aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrent-file-editor
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-04 11:33:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-03-04 11:33:50 +0000
commit89770e576be283cfde280f6eac1840e0028a582b (patch)
tree70cbbf5feb6d17c22b7aaaee4aa726067c6f0cf8 /net-p2p/torrent-file-editor
parent13b80b5d6704790a3a14701eb093d8bcd37fec26 (diff)
downloadports-89770e576be283cfde280f6eac1840e0028a582b.tar.gz
ports-89770e576be283cfde280f6eac1840e0028a582b.zip
net-p2p/torrent-file-editor: unbreak with libc++ 8
In file included from application.cpp:24: In file included from application.h:24: In file included from /usr/local/include/qt4/QtGui/QApplication:1: In file included from /usr/local/include/qt4/QtGui/qapplication.h:45: In file included from /usr/local/include/qt4/QtCore/qcoreapplication.h:45: In file included from /usr/local/include/qt4/QtCore/qobject.h:47: In file included from /usr/local/include/qt4/QtCore/qobjectdefs.h:45: In file included from /usr/local/include/qt4/QtCore/qnamespace.h:45: In file included from /usr/local/include/qt4/QtCore/qglobal.h:68: In file included from /usr/include/c++/v1/algorithm:640: In file included from /usr/include/c++/v1/initializer_list:47: In file included from /usr/include/c++/v1/cstddef:38: ./version:1:1: error: expected unqualified-id 0.3.13 ^ PR: 236192 Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=494587
Diffstat (limited to 'net-p2p/torrent-file-editor')
-rw-r--r--net-p2p/torrent-file-editor/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index 59948eb41bca..189567600bfb 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -41,4 +41,9 @@ DEPRECATED= Qt4 has been EOL since december 2015
EXPIRATION_DATE= 2019-03-15
.endif
+post-patch:
+# Avoid conflict with C++20 <version> by adding .txt suffix
+ @${REINPLACE_CMD} -i .c++20 '/file/s/version/&.txt/' \
+ ${WRKSRC}/Version.cmake ${WRKSRC}/Dmg.cmake
+
.include <bsd.port.mk>