aboutsummaryrefslogtreecommitdiff
path: root/net/fb303/files
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-15 22:12:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-15 22:12:40 +0000
commit2d09934671d017ce7c69bbfdde5661d6322d0adc (patch)
treead58ca7c799ce745438feb3736b4503652d3b72f /net/fb303/files
parentf2c87c052e70418f862418a0683aeddfbc89d354 (diff)
downloadports-2d09934671d017ce7c69bbfdde5661d6322d0adc.tar.gz
ports-2d09934671d017ce7c69bbfdde5661d6322d0adc.zip
New port: net/fb303: Base Thrift service and a common set of functionality
Notes
Notes: svn path=/head/; revision=548751
Diffstat (limited to 'net/fb303/files')
-rw-r--r--net/fb303/files/patch-build_fbcode__builder_CMake_FBThriftLibrary.cmake20
-rw-r--r--net/fb303/files/patch-fb303_thrift_CMakeLists.txt22
2 files changed, 42 insertions, 0 deletions
diff --git a/net/fb303/files/patch-build_fbcode__builder_CMake_FBThriftLibrary.cmake b/net/fb303/files/patch-build_fbcode__builder_CMake_FBThriftLibrary.cmake
new file mode 100644
index 000000000000..bee37e4a7901
--- /dev/null
+++ b/net/fb303/files/patch-build_fbcode__builder_CMake_FBThriftLibrary.cmake
@@ -0,0 +1,20 @@
+--- build/fbcode_builder/CMake/FBThriftLibrary.cmake.orig 2020-09-15 21:55:13 UTC
++++ build/fbcode_builder/CMake/FBThriftLibrary.cmake
+@@ -43,7 +43,7 @@ function(add_fbthrift_library LIB_NAME THRIFT_FILE)
+ set(PY_DEPENDS)
+ foreach(dep IN LISTS ARG_DEPENDS)
+ list(APPEND CPP_DEPENDS "${dep}_cpp")
+- list(APPEND PY_DEPENDS "${dep}_py")
++ #list(APPEND PY_DEPENDS "${dep}_py")
+ endforeach()
+
+ foreach(lang IN LISTS ARG_LANGUAGES)
+@@ -56,7 +56,7 @@ function(add_fbthrift_library LIB_NAME THRIFT_FILE)
+ INCLUDE_DIR "${ARG_INCLUDE_DIR}"
+ THRIFT_INCLUDE_DIR "${ARG_THRIFT_INCLUDE_DIR}"
+ )
+- elseif ("${lang}" STREQUAL "py" OR "${lang}" STREQUAL "python")
++ elseif (FALSE AND "${lang}" STREQUAL "py" OR "${lang}" STREQUAL "python")
+ if (DEFINED ARG_PY_NAMESPACE)
+ set(namespace_args NAMESPACE "${ARG_PY_NAMESPACE}")
+ endif()
diff --git a/net/fb303/files/patch-fb303_thrift_CMakeLists.txt b/net/fb303/files/patch-fb303_thrift_CMakeLists.txt
new file mode 100644
index 000000000000..07717fcee34b
--- /dev/null
+++ b/net/fb303/files/patch-fb303_thrift_CMakeLists.txt
@@ -0,0 +1,22 @@
+--- fb303/thrift/CMakeLists.txt.orig 2020-09-15 21:56:05 UTC
++++ fb303/thrift/CMakeLists.txt
+@@ -15,7 +15,7 @@
+ add_fbthrift_library(
+ fb303_thrift
+ fb303_core.thrift
+- LANGUAGES cpp py
++ LANGUAGES cpp
+ THRIFT_INCLUDE_DIR "${INCLUDE_INSTALL_DIR}/thrift-files"
+ SERVICES
+ BaseService
+@@ -38,8 +38,10 @@ install(
+ DESTINATION "$<TARGET_PROPERTY:fb303_thrift_cpp,THRIFT_INSTALL_DIR>"
+ )
+
++if (FALSE)
+ install_fb_python_library(fb303_thrift_py EXPORT fb303-exports)
+ install(
+ TARGETS fb303_thrift_py.thrift_includes
+ EXPORT fb303-exports
+ )
++endif()