aboutsummaryrefslogtreecommitdiff
path: root/net/gtk-vnc
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-12-16 19:32:34 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-12-16 19:32:34 +0000
commit261846f1578612bae246393aabe505a5eb5e823a (patch)
tree39125ad018c92a4f9d6c150f9320dc5066597324 /net/gtk-vnc
parent93959dc4105d5cce29ee1a0bec6affaf45d18dd7 (diff)
downloadports-261846f1578612bae246393aabe505a5eb5e823a.tar.gz
ports-261846f1578612bae246393aabe505a5eb5e823a.zip
Add gtk-vnc, a GTK+ VNC widget with C and Python bindings.
Notes
Notes: svn path=/head/; revision=203864
Diffstat (limited to 'net/gtk-vnc')
-rw-r--r--net/gtk-vnc/Makefile28
-rw-r--r--net/gtk-vnc/distinfo3
-rw-r--r--net/gtk-vnc/files/patch-examples_gvncviewer.c10
-rw-r--r--net/gtk-vnc/files/patch-src_continuation.h10
-rw-r--r--net/gtk-vnc/files/patch-src_coroutine.c11
-rw-r--r--net/gtk-vnc/files/patch-src_gvnc.c31
-rw-r--r--net/gtk-vnc/pkg-descr10
-rw-r--r--net/gtk-vnc/pkg-plist13
8 files changed, 116 insertions, 0 deletions
diff --git a/net/gtk-vnc/Makefile b/net/gtk-vnc/Makefile
new file mode 100644
index 000000000000..5ab9e0481b28
--- /dev/null
+++ b/net/gtk-vnc/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gtk-vnc
+# Date created: 16 December 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-vnc
+PORTVERSION= 0.3.1
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtk-vnc
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= VNC viewer widget for GTK+
+
+LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
+
+USE_XLIB= yes
+USE_GNOME= pygtk2 gnomehack
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_PYTHON= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/net/gtk-vnc/distinfo b/net/gtk-vnc/distinfo
new file mode 100644
index 000000000000..e319d5ed870c
--- /dev/null
+++ b/net/gtk-vnc/distinfo
@@ -0,0 +1,3 @@
+MD5 (gtk-vnc-0.3.1.tar.gz) = 00630dab5e6b0617e7baf320461d0127
+SHA256 (gtk-vnc-0.3.1.tar.gz) = 968011b4f69130c1fa287e134367c3a2d57a70947e6d1d5635a2df0839135a1b
+SIZE (gtk-vnc-0.3.1.tar.gz) = 379854
diff --git a/net/gtk-vnc/files/patch-examples_gvncviewer.c b/net/gtk-vnc/files/patch-examples_gvncviewer.c
new file mode 100644
index 000000000000..fe0579baffea
--- /dev/null
+++ b/net/gtk-vnc/files/patch-examples_gvncviewer.c
@@ -0,0 +1,10 @@
+--- examples/gvncviewer.c.orig 2007-12-16 14:02:33.000000000 -0500
++++ examples/gvncviewer.c 2007-12-16 14:02:44.000000000 -0500
+@@ -4,6 +4,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
diff --git a/net/gtk-vnc/files/patch-src_continuation.h b/net/gtk-vnc/files/patch-src_continuation.h
new file mode 100644
index 000000000000..549af869b8e7
--- /dev/null
+++ b/net/gtk-vnc/files/patch-src_continuation.h
@@ -0,0 +1,10 @@
+--- src/continuation.h.orig 2007-12-16 13:58:18.000000000 -0500
++++ src/continuation.h 2007-12-16 13:58:39.000000000 -0500
+@@ -11,6 +11,7 @@
+ #ifndef _CONTINUATION_H_
+ #define _CONTINUATION_H_
+
++#include <sys/types.h>
+ #include <ucontext.h>
+
+ struct continuation
diff --git a/net/gtk-vnc/files/patch-src_coroutine.c b/net/gtk-vnc/files/patch-src_coroutine.c
new file mode 100644
index 000000000000..1731a83898cb
--- /dev/null
+++ b/net/gtk-vnc/files/patch-src_coroutine.c
@@ -0,0 +1,11 @@
+--- src/coroutine.c.orig 2007-12-16 13:59:13.000000000 -0500
++++ src/coroutine.c 2007-12-16 13:59:21.000000000 -0500
+@@ -48,7 +48,7 @@ int coroutine_init(struct coroutine *co)
+ co->cc.stack_size = co->stack_size;
+ co->cc.stack = mmap(0, co->stack_size,
+ PROT_READ | PROT_WRITE,
+- MAP_PRIVATE | MAP_ANONYMOUS,
++ MAP_PRIVATE | MAP_ANON,
+ -1, 0);
+ if (co->cc.stack == MAP_FAILED)
+ return -1;
diff --git a/net/gtk-vnc/files/patch-src_gvnc.c b/net/gtk-vnc/files/patch-src_gvnc.c
new file mode 100644
index 000000000000..ac8825af6f67
--- /dev/null
+++ b/net/gtk-vnc/files/patch-src_gvnc.c
@@ -0,0 +1,31 @@
+--- src/gvnc.c.orig 2007-12-16 13:59:46.000000000 -0500
++++ src/gvnc.c 2007-12-16 14:01:54.000000000 -0500
+@@ -16,7 +16,7 @@
+
+ #include <netdb.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <errno.h>
+@@ -26,7 +26,19 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#ifdef __FreeBSD__
++#include <sys/endian.h>
++
++#define __BYTE_ORDER _BYTE_ORDER
++#define __LITTLE_ENDIAN _LITTLE_ENDIAN
++#define __BIG_ENDIAN _BIG_ENDIAN
++
++#define bswap_16 bswap16
++#define bswap_32 bswap32
++#define bswap_64 bswap64
++#else
+ #include <endian.h>
++#endif
+
+ #include "coroutine.h"
+ #include "d3des.h"
diff --git a/net/gtk-vnc/pkg-descr b/net/gtk-vnc/pkg-descr
new file mode 100644
index 000000000000..9077bc4993d6
--- /dev/null
+++ b/net/gtk-vnc/pkg-descr
@@ -0,0 +1,10 @@
+GTK-VNC is a VNC viewer widget for GTK+. It is built using coroutines,
+allowing it to be completely asynchronous while remaining single threaded.
+It supports RFB protocols 3.3 through 3.8 and the VeNCrypt authentication
+extension providing SSL/TLS encryption with x509 certificate authentication.
+The core library is written in C and a binding for Python using PyGTK is
+available. The networking layer supports connections over both IPv4 and IPv6.
+Example code illustrates how to build a vncviewer replacement using either C
+or Python.
+
+WWW: http://gtk-vnc.sourceforge.net/
diff --git a/net/gtk-vnc/pkg-plist b/net/gtk-vnc/pkg-plist
new file mode 100644
index 000000000000..b2ce5cd2dfdd
--- /dev/null
+++ b/net/gtk-vnc/pkg-plist
@@ -0,0 +1,13 @@
+include/gtk-vnc-1.0/continuation.h
+include/gtk-vnc-1.0/coroutine.h
+include/gtk-vnc-1.0/gvnc.h
+include/gtk-vnc-1.0/vncdisplay.h
+lib/libgtk-vnc-1.0.a
+lib/libgtk-vnc-1.0.la
+lib/libgtk-vnc-1.0.so
+lib/libgtk-vnc-1.0.so.0
+%%PYTHON_SITELIBDIR%%/gtkvnc.a
+%%PYTHON_SITELIBDIR%%/gtkvnc.la
+%%PYTHON_SITELIBDIR%%/gtkvnc.so
+libdata/pkgconfig/gtk-vnc-1.0.pc
+@dirrm include/gtk-vnc-1.0