aboutsummaryrefslogtreecommitdiff
path: root/net/hexinject/Makefile
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-10-25 13:13:41 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-10-25 13:13:41 +0000
commitc4d658de2e91d6826215a9eb4b58458a7d97a26f (patch)
tree2eaa99e9990cbf818df2a33acc42f8569b53d3a0 /net/hexinject/Makefile
parentde31d97d735ee18a1a2580c2d50919dbb697bc79 (diff)
downloadports-c4d658de2e91d6826215a9eb4b58458a7d97a26f.tar.gz
ports-c4d658de2e91d6826215a9eb4b58458a7d97a26f.zip
HexInject is a very versatile packet injector and sniffer, that provide a
command-line framework for raw network access. It's designed to work together with others command-line utilities, and for this reason it facilitates the creation of powerful shell scripts capable of reading, intercepting and modifying network traffic in a transparent manner. WWW: http://hexinject.sourceforge.net PR: ports/151670 Submitted by: Sofian Brabez <sbrabez at gmail.com>
Notes
Notes: svn path=/head/; revision=263567
Diffstat (limited to 'net/hexinject/Makefile')
-rw-r--r--net/hexinject/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/hexinject/Makefile b/net/hexinject/Makefile
new file mode 100644
index 000000000000..6abd2ef31bdc
--- /dev/null
+++ b/net/hexinject/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hexinject
+# Date created: 2010-10-24
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hexinject
+PORTVERSION= 1.1
+CATEGORIES= net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= HexInject is a very versatile packet injector and sniffer
+
+PLIST_FILES= bin/${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>