aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-06-14 13:22:42 +0000
committerCy Schubert <cy@FreeBSD.org>2021-06-14 16:04:00 +0000
commited47e1ecc5db5576f6a2d4a47e083b2366bd65cc (patch)
treed8855c464138a3c4f81eee0025928aa57be510fa /net/hostapd
parentc6f1867664d5ee44132e12d8ec53412b35754248 (diff)
downloadports-ed47e1ecc5db5576f6a2d4a47e083b2366bd65cc.tar.gz
ports-ed47e1ecc5db5576f6a2d4a47e083b2366bd65cc.zip
*/*: Sync hostapd* and wpa_supplicant* with base ce276fe26d92010776
Use IFM_IEEE80211_ADHOC for now on FreeBSD for IBSS operation. Base commit by adrian@ on Nov 26, 2015. This commit syncs ports with base. PR: 203086 Submitted by: avos MFH: 2020Q2
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile2
-rw-r--r--net/hostapd/files/patch-src_drivers_driver__bsd.c19
2 files changed, 18 insertions, 3 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index 1e70b2d5f2b2..f16516da9e6a 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hostapd
PORTVERSION= 2.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= https://w1.fi/releases/
diff --git a/net/hostapd/files/patch-src_drivers_driver__bsd.c b/net/hostapd/files/patch-src_drivers_driver__bsd.c
index 0a6812c26946..fe3064586710 100644
--- a/net/hostapd/files/patch-src_drivers_driver__bsd.c
+++ b/net/hostapd/files/patch-src_drivers_driver__bsd.c
@@ -1,5 +1,5 @@
--- src/drivers/driver_bsd.c.orig 2019-08-07 06:25:25.000000000 -0700
-+++ src/drivers/driver_bsd.c 2021-01-20 08:04:07.589603000 -0800
++++ src/drivers/driver_bsd.c 2021-06-13 23:10:12.570253000 -0700
@@ -649,7 +649,7 @@
len = 2048;
}
@@ -21,7 +21,22 @@
ether_sprintf(const u8 *addr)
{
static char buf[sizeof(MACSTR)];
-@@ -1336,14 +1340,18 @@
+@@ -1080,7 +1084,14 @@
+ mode = 0 /* STA */;
+ break;
+ case IEEE80211_MODE_IBSS:
++ /*
++ * Ref bin/203086 - FreeBSD's net80211 currently uses
++ * IFM_IEEE80211_ADHOC.
++ */
++#if 0
+ mode = IFM_IEEE80211_IBSS;
++#endif
++ mode = IFM_IEEE80211_ADHOC;
+ break;
+ case IEEE80211_MODE_AP:
+ mode = IFM_IEEE80211_HOSTAP;
+@@ -1336,14 +1347,18 @@
drv = bsd_get_drvindex(global, ifm->ifm_index);
if (drv == NULL)
return;