aboutsummaryrefslogtreecommitdiff
path: root/net/nepim
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-22 09:17:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-22 09:17:21 +0000
commitc5379e9cc6525486b933528586a004c9feb45cea (patch)
tree39923138d8151eafc7812f5abb263b6962aa4b91 /net/nepim
parent9b8b9c60e22fcec41059cbef737971570387d0c7 (diff)
downloadports-c5379e9cc6525486b933528586a004c9feb45cea.tar.gz
ports-c5379e9cc6525486b933528586a004c9feb45cea.zip
Nepim stands for network pipemeter, a tool for measuring available bandwidth
between hosts. nepim is also useful to generate network traffic for testing purposes. Nepim operates in client/server mode, is able to handle multiple parallel traffic streams, reports periodic partial statistics along the testing, and supports IPv6. PR: ports/86349 Submitted by: Marcin Jessa <yazzy@yazzy.org>
Notes
Notes: svn path=/head/; revision=143336
Diffstat (limited to 'net/nepim')
-rw-r--r--net/nepim/Makefile26
-rw-r--r--net/nepim/distinfo2
-rw-r--r--net/nepim/files/patch-Makefile17
-rw-r--r--net/nepim/pkg-descr10
4 files changed, 55 insertions, 0 deletions
diff --git a/net/nepim/Makefile b/net/nepim/Makefile
new file mode 100644
index 000000000000..bf4f7add22e6
--- /dev/null
+++ b/net/nepim/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: nepim
+# Date created: 19th September 2005
+# Whom: Marcin Jessa <yazzy@yazzy.org>
+# $FreeBSD$
+
+PORTNAME= nepim
+PORTVERSION= 0.13
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
+ http://www.yazzy.org/ports/
+MASTER_SITE_SUBDIR= nepim
+
+MAINTAINER= yazzy@yazzy.org
+COMMENT= Tool for measuring available bandwidth between hosts
+
+LIB_DEPENDS= oop.4:${PORTSDIR}/devel/liboop
+
+USE_GMAKE= yes
+ALL_TARGET= default
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+PLIST_FILES= bin/nepim
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nepim ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/nepim/distinfo b/net/nepim/distinfo
new file mode 100644
index 000000000000..c72f0007d768
--- /dev/null
+++ b/net/nepim/distinfo
@@ -0,0 +1,2 @@
+MD5 (nepim-0.13.tar.gz) = 532bf7067619771ecf3f12a33bf860c6
+SIZE (nepim-0.13.tar.gz) = 39917
diff --git a/net/nepim/files/patch-Makefile b/net/nepim/files/patch-Makefile
new file mode 100644
index 000000000000..7a275cbd7017
--- /dev/null
+++ b/net/nepim/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Tue Sep 13 01:41:41 2005
++++ Makefile Thu Sep 22 11:00:05 2005
+@@ -2,12 +2,12 @@
+ # $Id: Makefile,v 1.18 2005/09/12 23:41:41 evertonm Exp $
+ #
+
+-OOP_BASE = /usr/local/oop
++OOP_BASE = ${LOCALBASE}
+ OOP_INC = $(OOP_BASE)/include
+ OOP_LIB = $(OOP_BASE)/lib
+
+ CC = gcc
+-CFLAGS = -Wall -g -ggdb -I$(OOP_INC) -DHAVE_IPV6_MREQ
++CFLAGS += -Wall -I$(OOP_INC) -DHAVE_IPV6_MREQ
+ LDFLAGS = -L$(OOP_LIB) -loop
+
+ PLATFORM=$(shell uname)
diff --git a/net/nepim/pkg-descr b/net/nepim/pkg-descr
new file mode 100644
index 000000000000..1f71a84fbeb8
--- /dev/null
+++ b/net/nepim/pkg-descr
@@ -0,0 +1,10 @@
+Nepim stands for network pipemeter, a tool for measuring available bandwidth
+between hosts. nepim is also useful to generate network traffic for testing
+purposes. Nepim operates in client/server mode, is able to handle multiple
+parallel traffic streams, reports periodic partial statistics along the
+testing, and supports IPv6.
+
+WWW: http://www.nongnu.org/nepim/
+
+- Marcin Jessa
+yazzy@yazzy.org