aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-RTP
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /net/p5-Net-RTP
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'net/p5-Net-RTP')
-rw-r--r--net/p5-Net-RTP/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/p5-Net-RTP/Makefile b/net/p5-Net-RTP/Makefile
index 04a69fbc0577..2fff79fc11da 100644
--- a/net/p5-Net-RTP/Makefile
+++ b/net/p5-Net-RTP/Makefile
@@ -11,10 +11,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Send and receive RTP packets (RFC3550)
-RUN_DEPENDS= p5-IO-Socket-Multicast6>=0.02:${PORTSDIR}/net/p5-IO-Socket-Multicast6 \
+BUILD_DEPENDS= p5-IO-Socket-Multicast6>=0.02:${PORTSDIR}/net/p5-IO-Socket-Multicast6 \
p5-IO-Socket-Multicast>=1.00:${PORTSDIR}/net/p5-IO-Socket-Multicast \
p5-IO-Socket-INET6>=1.20:${PORTSDIR}/net/p5-IO-Socket-INET6 \
p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild