aboutsummaryrefslogtreecommitdiff
path: root/net/pecl-oauth
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:53:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:53:10 +0000
commitefc30ff07ea171d0355471b20280243cc3d2744a (patch)
tree32d88bd87ce438758eacac688b9050b5676240d8 /net/pecl-oauth
parent293c536e3694ff7e1678e4184ae0934c2ee8575c (diff)
downloadports-efc30ff07ea171d0355471b20280243cc3d2744a.tar.gz
ports-efc30ff07ea171d0355471b20280243cc3d2744a.zip
pecl-oauth is a php interface to the oauth protocol.
Oauth is an authorization protocol built on top of HTTP which allows applications to securely access data without having to store usernames and passwords. WWW: http://pecl.php.net/package/oauth/ PR: ports/129167 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=223573
Diffstat (limited to 'net/pecl-oauth')
-rw-r--r--net/pecl-oauth/Makefile28
-rw-r--r--net/pecl-oauth/distinfo3
-rw-r--r--net/pecl-oauth/pkg-descr6
3 files changed, 37 insertions, 0 deletions
diff --git a/net/pecl-oauth/Makefile b/net/pecl-oauth/Makefile
new file mode 100644
index 000000000000..4a8bf56a33a4
--- /dev/null
+++ b/net/pecl-oauth/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pecl-oauth
+# Date created: 25 Nov 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oauth
+PORTVERSION= 0.99.1
+CATEGORIES= net pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Php Interface to the OAuth Protocol
+
+BUILD_DEPENDS= ${LOCALBASE}/include/curl/curl.h:${PORTSDIR}/ftp/curl
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/net/pecl-oauth/distinfo b/net/pecl-oauth/distinfo
new file mode 100644
index 000000000000..91f83975b4ff
--- /dev/null
+++ b/net/pecl-oauth/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/oauth-0.99.1.tgz) = 8b828ac3f202f537fabc62c6a72feda4
+SHA256 (PECL/oauth-0.99.1.tgz) = d09cd5d0cf397db5da3a49c6fb94275ddc234e8555c77710dcf9510536e32415
+SIZE (PECL/oauth-0.99.1.tgz) = 12517
diff --git a/net/pecl-oauth/pkg-descr b/net/pecl-oauth/pkg-descr
new file mode 100644
index 000000000000..9da4a1e33c5e
--- /dev/null
+++ b/net/pecl-oauth/pkg-descr
@@ -0,0 +1,6 @@
+pecl-oauth is a php interface to the oauth protocol.
+Oauth is an authorization protocol built on top of
+HTTP which allows applications to securely access
+data without having to store usernames and passwords.
+
+WWW: http://pecl.php.net/package/oauth/