aboutsummaryrefslogtreecommitdiff
path: root/net/smm++
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-14 16:59:44 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-14 16:59:44 +0000
commit0923d840726f7f07f01e36cc84738e204d6201e1 (patch)
tree28411c6c63ce392a4fc56b707f4d851ed63cf3e8 /net/smm++
parent2e1bf085bc2e1492a7ed0e506071f8fd09b679b5 (diff)
downloadports-0923d840726f7f07f01e36cc84738e204d6201e1.tar.gz
ports-0923d840726f7f07f01e36cc84738e204d6201e1.zip
- Convert to USES=gmake and USES=tk
- STAGE-clean - Fix installed files and directories permissions
Notes
Notes: svn path=/head/; revision=339701
Diffstat (limited to 'net/smm++')
-rw-r--r--net/smm++/Makefile12
-rw-r--r--net/smm++/files/patch-Makefile37
2 files changed, 40 insertions, 9 deletions
diff --git a/net/smm++/Makefile b/net/smm++/Makefile
index 77a565a0ec7a..d4ab65a6f887 100644
--- a/net/smm++/Makefile
+++ b/net/smm++/Makefile
@@ -17,12 +17,18 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libitk.so:${PORTSDIR}/x11-toolkits/itk \
${LOCALBASE}/lib/libitcl.so:${PORTSDIR}/lang/itcl
WRKSRC= ${WRKDIR}/smm/Install.unix
-USE_GMAKE= yes
-USE_TK= 84+
+USES= gmake tk
EXTRACT_AFTER_ARGS=--exclude CVS
-NO_STAGE= yes
+MAKE_ENV+= STAGEDIR=${STAGEDIR}
+
post-patch:
${REINPLACE_CMD} -e 's,itkarray=.*,itkarray=${WISH},' ${WRKSRC}/itk.sh
+post-install:
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type f | ${XARGS} \
+ ${CHMOD} ${SHAREMODE}
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type d | ${XARGS} \
+ ${CHMOD} 755
+
.include <bsd.port.mk>
diff --git a/net/smm++/files/patch-Makefile b/net/smm++/files/patch-Makefile
index 0e56dffda4d8..abe0a9b273b5 100644
--- a/net/smm++/files/patch-Makefile
+++ b/net/smm++/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Wed May 1 17:15:20 2002
-+++ Makefile Wed Jun 12 20:02:20 2002
+--- Makefile.orig 2002-05-01 23:15:20.000000000 +0200
++++ Makefile 2014-01-14 17:56:34.000000000 +0100
@@ -11,8 +11,8 @@
# --- The default settings will install SMM++ nicely into an
@@ -11,12 +11,37 @@
# --- If you don't have root access, you could choose to install
# SMM++ locally in your home directory. Therefore use the
-@@ -57,6 +57,8 @@
- # --- You don't need to edit/understand/read the rest of
+@@ -58,6 +58,8 @@
# this Makefile. If you can read Makefiles, feel free
# to do whatever you like.
-+
-+all: smm
++all: smm
++
smm: Makefile
@echo "--- Building startup file."
+ @if [ -z ${ITKWISH} ] ; then \
+@@ -80,18 +82,18 @@
+ @echo "--- Installing startup file to '${BIN}'."
+ @echo " Please make sure, that '${BIN}' is part of your PATH variable."
+ @echo " Or start SMM++ with ${BIN}/smm."
+- @install -d ${BIN}
+- @install -c smm ${BIN}
++ @install -d ${STAGEDIR}${BIN}
++ @install -c smm ${STAGEDIR}${BIN}
+ uninstall-bin:
+ @echo "--- Uninstalling startup file from '${BIN}'."
+ @echo " Leaving the bin-dir untouched."
+ @rm -f ${BIN}/smm
+ install-src:
+ @echo "--- Installing libraries to ${SRC}."
+- @install -d ${SRC}
+- @cp -Rp ../sources ${SRC}
+- @cp -Rp ../images ${SRC}
+- @cp -Rp ../config ${SRC}
++ @install -d ${STAGEDIR}${SRC}
++ @cp -Rp ../sources ${STAGEDIR}${SRC}
++ @cp -Rp ../images ${STAGEDIR}${SRC}
++ @cp -Rp ../config ${STAGEDIR}${SRC}
+ uninstall-src:
+ @echo "--- Uninstalling libraries from ${SRC}."
+ @rm -rf ${SRC}