aboutsummaryrefslogtreecommitdiff
path: root/net/spread
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-02 18:39:11 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-02 18:39:11 +0000
commitf3f82255922f3290d7a01b6726feba70a7a2aed2 (patch)
tree3c0ec6e2c2449f0db6aa02378b5f80f3411e8034 /net/spread
parent0aad97bb5c24e162fa1f0e0fa87c8654f738ff52 (diff)
downloadports-f3f82255922f3290d7a01b6726feba70a7a2aed2.tar.gz
ports-f3f82255922f3290d7a01b6726feba70a7a2aed2.zip
- Fix INDEX
Notes
Notes: svn path=/head/; revision=324172
Diffstat (limited to 'net/spread')
-rw-r--r--net/spread/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/net/spread/Makefile b/net/spread/Makefile
index dfbec48f6917..682e81ca25de 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -20,7 +20,7 @@ MAKE_JOBS_UNSAFE= yes
PORTSCOUT= limit:^3
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
USE_RC_SUBR= spread
USE_LDCONFIG= yes
@@ -45,10 +45,8 @@ MAN3= libsp.3 SP_connect.3 SP_disconnect.3 SP_equal_group_ids.3 \
.include <bsd.port.pre.mk>
-USES= perl5
-USE_PERL5= configure
-USES= perl5
-USE_PERL5= configure
+# bsd.port.mk doesn't allow us to use GNU_CONFIGURE and PERL_CONFIGURE together.
+PERL_CONFIGURE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}" \
INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib"
_MANPAGES+= ${PREFIX}/lib/perl5/${PERL_VER}/man/man3/Spread.3
@@ -59,8 +57,7 @@ post-configure:
post-build:
@cd ${WRKSRC}/perl/Spread && \
-USES= perl5
-USE_PERL5= configure
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./Makefile.PL ${PERL_CONFIGURE_ARGS}
@cd ${WRKSRC}/perl/Spread && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
@cd ${WRKSRC}/perl/Spread && ${MAKE}