aboutsummaryrefslogtreecommitdiff
path: root/net/tridiavnc
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-15 22:36:00 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-15 22:36:00 +0000
commit7ccf0c384869c9db2fcd910959114867234e07c9 (patch)
treec2aacbeb49f3a9e4d5b680fb47965561c81cb97d /net/tridiavnc
parent478fe098ef0aa9b70f7e1a77fc57a3a71a64bda5 (diff)
downloadports-7ccf0c384869c9db2fcd910959114867234e07c9.tar.gz
ports-7ccf0c384869c9db2fcd910959114867234e07c9.zip
Add TridiaVNC, a version of VNC that provides more options and
commercial support. Currently Xvnc doesn't compile on FreeBSD for some strange reason
Notes
Notes: svn path=/head/; revision=44046
Diffstat (limited to 'net/tridiavnc')
-rw-r--r--net/tridiavnc/Makefile37
-rw-r--r--net/tridiavnc/distinfo1
-rw-r--r--net/tridiavnc/files/patch-main-Imakefile10
-rw-r--r--net/tridiavnc/files/patch-viewer-Imakefile8
-rw-r--r--net/tridiavnc/pkg-comment1
-rw-r--r--net/tridiavnc/pkg-descr7
-rw-r--r--net/tridiavnc/pkg-plist18
7 files changed, 82 insertions, 0 deletions
diff --git a/net/tridiavnc/Makefile b/net/tridiavnc/Makefile
new file mode 100644
index 000000000000..7d8629651f86
--- /dev/null
+++ b/net/tridiavnc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: tridiavnc
+# Date created: 14 June 2001
+# Whom: dwcjr
+#
+# $FreeBSD$
+#
+
+PORTNAME= tridiavnc
+PORTVERSION= 1.4
+CATEGORIES= net
+MASTER_SITES= http://www.developvnc.org/logged-in/downloadnow/
+DISTNAME= DevVNC_unix
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dwcjr@freebsd.org
+
+USE_PERL5= yes
+WRKSRC= ${WRKDIR}/unix/vnc_unixsrc
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+
+# We have to frob a few things, and we want our own permissions, so it's easier
+# to do the install ourselves.
+post-install:
+# ${INSTALL_PROGRAM} ${WRKSRC}/Xvnc/programs/Xserver/Xvnc ${PREFIX}/bin/Xvnc
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncviewer/vncviewer ${PREFIX}/bin/vncviewer
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncpasswd/vncpasswd ${PREFIX}/bin/vncpasswd
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncconnect/vncconnect ${PREFIX}/bin/vncconnect
+ ${SED} -e s%/usr/local/vnc/classes%${PREFIX}/share/vnc/classes% \
+ -e s%^\#!/usr/bin/perl%\#!${PERL}% \
+ < ${WRKSRC}/vncserver \
+ > ${WRKSRC}/vncserver.local
+ ${INSTALL_SCRIPT} ${WRKSRC}/vncserver.local ${PREFIX}/bin/vncserver
+# Go install Java classes
+ ${MKDIR} ${PREFIX}/share/vnc
+ ${CP} -R ${WRKSRC}/classes ${PREFIX}/share/vnc
+.include <bsd.port.mk>
diff --git a/net/tridiavnc/distinfo b/net/tridiavnc/distinfo
new file mode 100644
index 000000000000..e76bddad0bfc
--- /dev/null
+++ b/net/tridiavnc/distinfo
@@ -0,0 +1 @@
+MD5 (DevVNC_unix.tgz) = e25ea9d84da6e009990bd5c94a8c0552
diff --git a/net/tridiavnc/files/patch-main-Imakefile b/net/tridiavnc/files/patch-main-Imakefile
new file mode 100644
index 000000000000..cf5e0229a6c5
--- /dev/null
+++ b/net/tridiavnc/files/patch-main-Imakefile
@@ -0,0 +1,10 @@
+--- Imakefile.orig Thu Jun 14 14:42:57 2001
++++ Imakefile Thu Jun 14 14:43:05 2001
+@@ -14,6 +14,7 @@
+ @echo Built $(SUBDIRS).
+ @echo 'To build Xvnc, do "cd Xvnc", followed by "make World"'
+ @echo ""
++ (cd Xvnc; make World)
+
+ MakeSubdirs($(SUBDIRS))
+ DependSubdirs($(SUBDIRS))
diff --git a/net/tridiavnc/files/patch-viewer-Imakefile b/net/tridiavnc/files/patch-viewer-Imakefile
new file mode 100644
index 000000000000..802db722c4b6
--- /dev/null
+++ b/net/tridiavnc/files/patch-viewer-Imakefile
@@ -0,0 +1,8 @@
+--- vncviewer/Imakefile.orig Thu Jun 14 14:45:01 2001
++++ vncviewer/Imakefile Thu Jun 14 14:45:16 2001
+@@ -41,4 +41,4 @@
+
+ OBJS = $(SRCS:.c=.o)
+
+-ComplexProgramTarget(vncviewer)
++ComplexProgramTargetNoMan(vncviewer)
diff --git a/net/tridiavnc/pkg-comment b/net/tridiavnc/pkg-comment
new file mode 100644
index 000000000000..65d65b23e63d
--- /dev/null
+++ b/net/tridiavnc/pkg-comment
@@ -0,0 +1 @@
+Display X and Win32 desktops on remote X/Win32/Java displays
diff --git a/net/tridiavnc/pkg-descr b/net/tridiavnc/pkg-descr
new file mode 100644
index 000000000000..02dd35ca33d6
--- /dev/null
+++ b/net/tridiavnc/pkg-descr
@@ -0,0 +1,7 @@
+"VNC stands for Virtual Network Computing. It is, in essence, a remote
+ display system which allows you to view a computing 'desktop'
+ environment not only on the machine where it is running, but from
+ anywhere on the Internet and from a wide variety of machine
+ architectures."
+
+WWW: http://www.uk.research.att.com/vnc/
diff --git a/net/tridiavnc/pkg-plist b/net/tridiavnc/pkg-plist
new file mode 100644
index 000000000000..c5516ae2ecfd
--- /dev/null
+++ b/net/tridiavnc/pkg-plist
@@ -0,0 +1,18 @@
+@comment bin/Xvnc
+bin/vncviewer
+bin/vncpasswd
+bin/vncserver
+bin/vncconnect
+share/vnc/classes/DesCipher.class
+share/vnc/classes/animatedMemoryImageSource.class
+share/vnc/classes/authenticationPanel.class
+share/vnc/classes/clipboardFrame.class
+share/vnc/classes/index.vnc
+share/vnc/classes/optionsFrame.class
+share/vnc/classes/rfbProto.class
+share/vnc/classes/shared.vnc
+share/vnc/classes/vncCanvas.class
+share/vnc/classes/vncviewer.class
+share/vnc/classes/vncviewer.jar
+@dirrm share/vnc/classes
+@dirrm share/vnc