aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-18 15:14:57 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-18 15:14:57 +0000
commit2f31f6488fc45cfcb998f900f0bb0e7987a6b06e (patch)
treeb61b1965e672cbfbc413084d564e65454bf0286a /net
parentf84bddd9c2463df378b01403cde0d0433c25b7dd (diff)
downloadports-2f31f6488fc45cfcb998f900f0bb0e7987a6b06e.tar.gz
ports-2f31f6488fc45cfcb998f900f0bb0e7987a6b06e.zip
Convert to USES=autoreconf
Notes
Notes: svn path=/head/; revision=384229
Diffstat (limited to 'net')
-rw-r--r--net/afpfs-ng/Makefile5
-rw-r--r--net/bmon/Makefile4
-rw-r--r--net/freeradius2/Makefile19
-rw-r--r--net/isc-dhcp41-server/Makefile4
-rw-r--r--net/libnfs/Makefile6
-rw-r--r--net/libsocket++/Makefile4
-rw-r--r--net/ntopng/Makefile4
-rw-r--r--net/openggsn/Makefile6
-rw-r--r--net/rabbitmq-c/Makefile4
-rw-r--r--net/tigervnc/Makefile5
-rw-r--r--net/torsocks/Makefile4
11 files changed, 19 insertions, 46 deletions
diff --git a/net/afpfs-ng/Makefile b/net/afpfs-ng/Makefile
index 92f29ca5db0c..c698a83bbf67 100644
--- a/net/afpfs-ng/Makefile
+++ b/net/afpfs-ng/Makefile
@@ -12,10 +12,9 @@ COMMENT= Apple Filing Protocol client library
LICENSE= GPLv2
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake iconv libtool tar:bzip2 readline
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-AUTOMAKE_ARGS= --add-missing --copy --force
+USES= autoreconf gmake iconv libtool readline tar:bzip2
USE_LDCONFIG= yes
CFLAGS+= -Wno-return-type
diff --git a/net/bmon/Makefile b/net/bmon/Makefile
index 9ce9fff230a8..3d61cc8469d6 100644
--- a/net/bmon/Makefile
+++ b/net/bmon/Makefile
@@ -20,10 +20,8 @@ GH_ACCOUNT= tgraf
GH_COMMIT= ad62e66
GH_TAGNAME= v${PORTVERSION}
-USES= ncurses pkgconfig:build
-USE_AUTOTOOLS= libtoolize autoheader automake aclocal
-AUTOMAKE_ARGS+= --add-missing
GNU_CONFIGURE= yes
+USES= autoreconf ncurses pkgconfig:build
OPTIONS_DEFINE= DOCS
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index 7125490c4bff..20122717af44 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -28,9 +28,9 @@ CONFLICTS_INSTALL= gnu-radius-[0-9].* openradius-[0-9].* radiusd-cistron-[0-9].*
USE_RC_SUBR= radiusd
-USES= gmake libtool shebangfix tar:bzip2 libtool autoreconf
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool shebangfix tar:bzip2
SHEBANG_FILES= scripts/radsqlrelay src/modules/rlm_counter/rad_counter
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader
USE_OPENSSL= yes
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= ${CPPFLAGS}
@@ -309,14 +309,14 @@ CONFIGURE_ARGS+=--with-openssl-libraries=${OPENSSLLIB}
post-patch:
# never try to find execinfo.h (needed until we can enable/disable backtrace
- @${REINPLACE_CMD} -e '/execinfo.h/d' ${WRKSRC}/configure \
- ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} '/execinfo.h/d' ${WRKSRC}/configure.in
# Patch raddb/certs/Makefile for the full path to the openssl binary (using
# ports OpenSSL if installed)
@${REINPLACE_CMD} -E \
-e "s:^([[:space:]])+openssl:\1${OPENSSLBASE}/bin/openssl:g" \
${WRKSRC}/raddb/certs/Makefile
# If we're using Heimdal from base, alter the LIBS variable
+# XXX Should patch configure.in instead of configure because it is regenerated
.if ${PORT_OPTIONS:MHEIMDAL} && empty(PORT_OPTIONS:MHEIMDAL_PORT)
@${REINPLACE_CMD} -e 's|LIBS|KRB5LIBS|g' ${WRKSRC}/src/modules/rlm_krb5/configure
@${REINPLACE_CMD} -e 's|-lkrb5|$$(${KRB5_CONFIG})|g' \
@@ -331,17 +331,6 @@ post-patch:
@${REINPLACE_CMD} -Ee 's:^(.+rc\.radiusd.+)$$:#\1:g' \
${WRKSRC}/scripts/Makefile
-pre-configure:
-# Force the rebuild of some configures from configure.in, as we're patching
-# the configure.in
-# NOTE: ${WRKSRC}/configure is rebuilt automatically once autoconf is
-# added to USE_AUTOTOOLS
- @cd ${WRKSRC}/src/modules/rlm_ldap && ${AUTOCONF} -I ${WRKSRC}
- @cd ${WRKSRC}/src/modules/rlm_sql/drivers/rlm_sql_mysql \
- && ${AUTOCONF} -I ${WRKSRC}
- @cd ${WRKSRC}/src/modules/rlm_perl && ${AUTOCONF} -I ${WRKSRC}
- @cd ${WRKSRC}/src/modules/rlm_python && ${AUTOCONF} -I ${WRKSRC}
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}-${PORTVERSION}/*.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/rlm_* \
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index 6baa57a96618..a2e36c230e25 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -96,11 +96,9 @@ PLIST_SUB+= SCHEMA_DIR="${SCHEMA_DIR:S,^${PREFIX}/,,}" LDAP=""
PORTDOCS+= README.ldap LICENSE.ldap
LDAP_SCRIPT= ${WRKDIR}/${LDAPPATCHDIST}/dhcpd-conf-to-ldap
LDAP_SCHEMA= ${WRKDIR}/${LDAPPATCHDIST}/dhcp.schema
-USES+= perl5
+USES+= autoreconf perl5
USE_PERL5= run
USE_OPENLDAP= yes
-USE_AUTOTOOLS= aclocal libtoolize autoconf autoheader automake
-AUTOMAKE_ARGS= --foreign --add-missing --copy
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/libnfs/Makefile b/net/libnfs/Makefile
index 898663c5bcaa..547e62588cb3 100644
--- a/net/libnfs/Makefile
+++ b/net/libnfs/Makefile
@@ -14,10 +14,8 @@ LICENSE= LGPL21 GPLv3
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig gmake libtool
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-ACLOCAL_ARGS= -I.
-AUTOMAKE_ARGS= --add-missing
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool pkgconfig
USE_LDCONFIG= yes
post-patch:
diff --git a/net/libsocket++/Makefile b/net/libsocket++/Makefile
index ca5c30e3ac02..26ed93c4a80b 100644
--- a/net/libsocket++/Makefile
+++ b/net/libsocket++/Makefile
@@ -18,9 +18,7 @@ OPTIONS_DEFINE= DOCS
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= libtool makeinfo
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-AUTOMAKE_ARGS= -a -c
+USES= autoreconf libtool makeinfo
INFO= socket++
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index 7b1adc67133f..ba986bfc0e81 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -20,11 +20,11 @@ LIB_DEPENDS= librrd.so:${PORTSDIR}/databases/rrdtool \
libndpi.so:${PORTSDIR}/net/ndpi \
libzmq.so:${PORTSDIR}/net/libzmq3
-USE_AUTOTOOLS= autoheader aclocal libtoolize
+GNU_CONFIGURE= yes
USE_SQLITE= yes
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= cpe gmake libtool pathfix pkgconfig tar:tgz
+USES= autoreconf cpe gmake libtool pathfix pkgconfig tar:tgz
SUB_FILES= ntopng-geoipupdate.sh
CPE_VENDOR= ntop
diff --git a/net/openggsn/Makefile b/net/openggsn/Makefile
index 51640bcd61bf..4ca675e028fd 100644
--- a/net/openggsn/Makefile
+++ b/net/openggsn/Makefile
@@ -12,10 +12,8 @@ COMMENT= Implementation of the Gateway GPRS Support Node element
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool
-
-USE_AUTOTOOLS= aclocal autoconf automake libtoolize autoheader
-AUTOMAKE_ARGS= --gnu --add-missing --copy
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool
post-patch:
${REINPLACE_CMD} -e 's|pkgconfigdir.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g' \
diff --git a/net/rabbitmq-c/Makefile b/net/rabbitmq-c/Makefile
index c5653232429f..a75ecb4cb9ce 100644
--- a/net/rabbitmq-c/Makefile
+++ b/net/rabbitmq-c/Makefile
@@ -25,10 +25,8 @@ CONFLICTS= rabbitmq-c-devel-[0-9]*
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool python tar:bzip2
+USES= autoreconf gmake libtool python tar:bzip2
USE_LDCONFIG= yes
-USE_AUTOTOOLS= aclocal autoconf automake autoheader libtoolize
-AUTOMAKE_ARGS= -i --add-missing
OPTIONS_DEFINE= 64BIT POPT
64BIT_DESC= Produce 64-bit library
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index fc3e92916d4b..d6f8a06fd89e 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -24,9 +24,8 @@ CONFLICTS= tridiavnc-[0-9]* \
tightvnc-[0-9]* \
vnc-[0-9]*
-USES= cmake cpe gmake libtool pkgconfig python
+USES= autoreconf:build cmake cpe gmake libtool pkgconfig python
USE_GL= gl
-USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
USE_LDCONFIG= yes
USE_OPENSSL= yes
@@ -132,7 +131,7 @@ post-patch:
@cd ${WRKSRC}/unix/xserver/ && ${PATCH} -p1 < ${WRKSRC}/unix/xserver${TIGERVNC_XORG_PATCH_VER}.patch
post-configure:
- @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${AUTORECONF} -fiv
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${LOCALBASE}/bin/autoreconf -fiv
@cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
post-build:
diff --git a/net/torsocks/Makefile b/net/torsocks/Makefile
index ec9a901db07b..b4019e2f5456 100644
--- a/net/torsocks/Makefile
+++ b/net/torsocks/Makefile
@@ -17,9 +17,7 @@ GH_ACCOUNT= dgoulet
GH_PROJECT= torsocks
GH_TAGNAME= 96f7a0d
-USE_AUTOTOOLS= aclocal autoconf libtoolize
-ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
-
+GNU_CONFIGURE= yes
USES= autoreconf gmake libtool
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip