aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
commitd09ed096c44ca516f3e4922e292b4afabd03ff11 (patch)
tree8472e59ca02578120ca7b8bc5e2af50d2954440e /net
parent31a195fb72446a7d02336b8fa1b9c1e0032f95cb (diff)
downloadports-d09ed096c44ca516f3e4922e292b4afabd03ff11.tar.gz
ports-d09ed096c44ca516f3e4922e292b4afabd03ff11.zip
*/*: Replace USE_GCC=any with USE_GCC=yes
USE_GCC=any has been equivalent to USE_GCC=yes in most cases (such as i386 and amd64 since 12.x and depending on configuration 11.x, most newer installations on other platforms, and 13.x across the board). Since commit 96c17633d90386b5bcf8 Mk/bsd.gcc.mk is treating them as different spellings of the same, so continue the deorbiting of the USE_GCC=any form and simply replace it with USE_GCC=yes. This should not make any functional difference at all. Discussed with: mat, linimon, pkubaj
Diffstat (limited to 'net')
-rw-r--r--net/libtnl/Makefile2
-rw-r--r--net/nepenthes/Makefile2
-rw-r--r--net/tightvnc/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/net/libtnl/Makefile b/net/libtnl/Makefile
index 2b010bbfd048..580d3985d941 100644
--- a/net/libtnl/Makefile
+++ b/net/libtnl/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
USES= uidfix
-USE_GCC= any
+USE_GCC= yes
WRKSRC= ${WRKDIR}/tnl/tnl
USE_LDCONFIG= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index 1841e160b1a6..a477d0452935 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
USES= dos2unix libtool perl5
USE_CXXSTD= gnu++98
-USE_GCC= any
+USE_GCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
INSTALL_TARGET= install-strip
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 8cdae360d05f..491c709fc2f3 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -44,7 +44,7 @@ PREFIX=${TIGHTVNC_BASE}
.include <bsd.port.pre.mk>
.if ${ARCH} == aarch64 || ${ARCH:Mpowerpc64*} || ${ARCH} == riscv64
-USE_GCC= any
+USE_GCC= yes
.endif
.if exists(${PREFIX}/share/vnc/classes/index.vnc)