aboutsummaryrefslogtreecommitdiff
path: root/print/freetype2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
commitb1bf1620a6571c5eb84bed4e3f06cf52094d0a48 (patch)
tree93506aaee5230ee46b75930c4b3a6b8e0f243d74 /print/freetype2/Makefile
parent123411e1ee17366ee88efd54b8482949b8e76eb5 (diff)
downloadports-b1bf1620a6571c5eb84bed4e3f06cf52094d0a48.tar.gz
ports-b1bf1620a6571c5eb84bed4e3f06cf52094d0a48.zip
Update freetype to 2.5.2.
Remove patch to add -I/usr/local/include in freetype-config --cflags. If ports need extra headers they should look for them, and not get them via a side-effect. Freetype had a header resuffle in 2.5.1, patch ports to use the new header style. Thanks go to bdrewery for the two exp-runs and rakuco for helping me with some troublesome cmake ports. PR: ports/184587
Notes
Notes: svn path=/head/; revision=337385
Diffstat (limited to 'print/freetype2/Makefile')
-rw-r--r--print/freetype2/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index c8e966b4f7ca..db602a411cda 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -3,7 +3,7 @@
# $MCom: ports/print/freetype2/Makefile,v 1.28 2011/10/25 18:31:21 kwm Exp $
PORTNAME= freetype2
-PORTVERSION= 2.5.0.1
+PORTVERSION= 2.5.2
CATEGORIES= print
MASTER_SITES= SF/freetype/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}/ \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/freetype2/ \
@@ -16,21 +16,19 @@ DISTNAME= ${PORTNAME:S/2//}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Free and portable TrueType font rendering engine
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USES= gmake
MAKE_ENV= TOP=""
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= ltverhack:9
-LIBTOOLFILES= builds/unix/configure
+ltverhack_PATCH_FILES= builds/unix/ltmain.sh
CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
OPTIONS_DEFINE= LCD_FILTERING PNG
LCD_FILTERING_DESC?= Sub-pixel rendering (patented)
PNG_DESC= Png compressed OpenType embedded bitmaps support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLCD_FILTERING}
@@ -47,12 +45,11 @@ pre-patch:
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/builds/unix/install.mk
-pre-configure:
- @${REINPLACE_CMD} -e '/^LIBTOOL/s|LIBTOOL := $$(FT_LIBTOOL_DIR)/libtool|LIBTOOL := ${WRKDIR}/gnome-libtool|' \
- ${WRKSRC}/builds/unix/unix-cc.in
-
post-configure:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} setup)
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfreetype.so.9
+
.include <bsd.port.mk>