aboutsummaryrefslogtreecommitdiff
path: root/print/photoprint
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2018-01-17 14:35:30 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2018-01-17 14:35:30 +0000
commitae01866731bb8c76a5008b2194e4364b01f10a65 (patch)
treecb6567387fcf659febc9fe52435e2ada9cf00bca /print/photoprint
parentee6d254d2d3df107ec8e1188e651bae95fe022f8 (diff)
downloadports-ae01866731bb8c76a5008b2194e4364b01f10a65.tar.gz
ports-ae01866731bb8c76a5008b2194e4364b01f10a65.zip
print/photoprint: Fix build with clang6, USES+=localbase
. fix build with clang6 by forcing --std=gnu++98; . incorporate USES+=localbase; . spaces->tabs at a makefile assignment.
Notes
Notes: svn path=/head/; revision=459261
Diffstat (limited to 'print/photoprint')
-rw-r--r--print/photoprint/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
index 9791f594abce..d106c6d7d717 100644
--- a/print/photoprint/Makefile
+++ b/print/photoprint/Makefile
@@ -21,14 +21,13 @@ LIB_DEPENDS= libcups.so:print/cups \
libtiff.so:graphics/tiff
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext jpeg libtool pkgconfig
-USE_GNOME= cairo gdkpixbuf2 gtk20
+USES= desktop-file-utils gettext jpeg libtool localbase pkgconfig
+USE_GNOME= cairo gdkpixbuf2 gtk20
USE_XORG= x11
+USE_CXXSTD= gnu++98
+LIBS+= -lX11
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lX11
-
post-patch:
@${REINPLACE_CMD} -e 's|glib/gstrfuncs.h|glib.h|g' \
${WRKSRC}/gp_cppsupport/gprinter.cpp