aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-01-23 22:16:07 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-01-23 22:16:07 +0000
commitbf62f427550ec28f95d9acfd7dcfb7e4fa221446 (patch)
tree8d45963a1a3ba4eb0ebf2d0848b56d47e53e9208 /print
parent6a6c005c723f347d302173498e063465d3269b88 (diff)
downloadports-bf62f427550ec28f95d9acfd7dcfb7e4fa221446.tar.gz
ports-bf62f427550ec28f95d9acfd7dcfb7e4fa221446.zip
fix all outstanding problems except printing test page
Notes
Notes: svn path=/head/; revision=73885
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile16
-rw-r--r--print/cups-base/pkg-message2
-rw-r--r--print/cups-base/pkg-plist3
-rw-r--r--print/cups-lpr/Makefile2
-rw-r--r--print/cups/Makefile2
-rw-r--r--print/cups/Makefile.common8
6 files changed, 24 insertions, 9 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index ae7b70ca248b..299fe851844e 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -9,19 +9,29 @@
PORTNAME= cups-base
PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= ${CUPS_PORTEPOCH}
CATEGORIES= print
MASTER_SITES= ${CUPS_MASTER_SITES}
MAINTAINER= alane@FreeBSD.org
+pre-install:
+ -@${ECHO_CMD} "===>" Stopping cupsd ...
+ -killall cupsd || true
+ -rm -fr ${PREFIX}/etc/cups/certs/* || true
+
post-install:
- cd ${PREFIX}/etc/rc.d; ${MV} cups cups.sh.sample
+ cd ${CUPS_RCDIR}; ${MV} cups cups.sh.sample
${FIND} ${PREFIX}/man/cat* -type l -name '*.0' -delete
${FIND} ${PREFIX}/man/fr/cat* -type l -name '*.0' -delete
- ${MKDIR} ${CUPS_SPOOLDIR}
+ ${MKDIR} ${CUPS_SPOOLDIR} ${CUPS_SPOOLDIR}/tmp
${CHOWN} -R ${CUPSOWN}:${CUPSGRP} ${CUPS_SPOOLDIR}
+ ${CHMOD} -R g+w ${CUPS_SPOOLDIR}
+.for f in classes.conf client.conf cupsd.conf printers.conf
+ cd ${CUPS_ETCDIR};\
+ if test ! -f ${f}.N; then cp -p ${f} ${f}.N; else true; fi
+.endfor # classes.conf client.conf cupsd.conf printers.conf
.include "${.CURDIR}/../../print/cups/Makefile.common"
.include <bsd.port.pre.mk>
diff --git a/print/cups-base/pkg-message b/print/cups-base/pkg-message
index dab2c7fec5ba..a1d30ff53ace 100644
--- a/print/cups-base/pkg-message
+++ b/print/cups-base/pkg-message
@@ -7,7 +7,7 @@ Once the package is installed, please do the following (as root):
cd /var/spool
mkdir -p cups/tmp
- chown -R daemon:wheel cups
+ chown -R root:daemon cups
Thanks.
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index 6ab0ec408725..a79a51de53a8 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -1,3 +1,6 @@
+@exec /bin/echo "===>" Stopping cupsd ...
+@exec /usr/bin/killall cupsd || true
+@exec /bin/rm -fr %D/etc/cups/certs/* 2>/dev/null || true
bin/cups-config
etc/cups/classes.conf.N
etc/cups/client.conf.N
diff --git a/print/cups-lpr/Makefile b/print/cups-lpr/Makefile
index 7440f33a4f6f..f2bf685cd90f 100644
--- a/print/cups-lpr/Makefile
+++ b/print/cups-lpr/Makefile
@@ -9,7 +9,7 @@
PORTNAME= cups-lpr
PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= 0
+PORTREVISION= 2
PORTEPOCH= ${CUPS_PORTEPOCH}
CATEGORIES= print
MASTER_SITES= ${CUPS_MASTER_SITES}
diff --git a/print/cups/Makefile b/print/cups/Makefile
index 502e1ae40381..60442ada7c44 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -9,7 +9,7 @@
PORTNAME= cups
PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= ${CUPS_PORTEPOCH}
CATEGORIES= print
MASTER_SITES= # empty
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
index 1bccb425fcc1..420de4bb0631 100644
--- a/print/cups/Makefile.common
+++ b/print/cups/Makefile.common
@@ -14,12 +14,14 @@ CUPS_REVISION= 0
CUPS_PORTVER= ${CUPS_VERSION}.${CUPS_REVISION}
CUPS_PORTEPOCH= 0
CUPS_FILESDIR= ${.CURDIR}/../../print/cups/files
+CUPS_ETCDIR= ${PREFIX}/etc/cups
+CUPS_RCDIR= ${PREFIX}/etc/rc.d
CUPS_DOCSDIR= ${PREFIX}/share/doc/cups
CUPS_SPOOLDIR= /var/spool/cups
# file, dir ownership
-CUPSGRP= wheel
-CUPSOWN= daemon
+CUPSGRP= daemon
+CUPSOWN= root
######################################################################
# The rest of the file is for components (cups-base, cups-lpr) only.
@@ -54,7 +56,7 @@ CONFIGURE_ARGS+= --localstatedir=/var \
--with-cups-user=${CUPSOWN} \
--with-cups-group=${CUPSGRP} \
--with-docdir=${CUPS_DOCSDIR} \
- --with-rcdir=${PREFIX}/etc/rc.d
+ --with-rcdir=${CUPS_RCDIR}
CONFIGURE_ARGS+= CPPFLAGS="-I${PREFIX}/include"
CONFIGURE_ARGS+= CFLAGS="${CFLAGS} -I.. -I${PREFIX}/include"