aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-05 01:29:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-05 01:31:24 +0000
commit521a9557f0bb69046cffd25dfd76a3ff3798bd99 (patch)
treee3b7d5771f964c232235ba14328e07364292ecf6 /science
parente8cc50a10937e2df4b591c87217bf3dc6334c6d1 (diff)
downloadports-521a9557f0bb69046cffd25dfd76a3ff3798bd99.tar.gz
ports-521a9557f0bb69046cffd25dfd76a3ff3798bd99.zip
science/plumed: Add missing dependencies and binary alias which fixes most tests.
Diffstat (limited to 'science')
-rw-r--r--science/plumed/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/science/plumed/Makefile b/science/plumed/Makefile
index 72f7d9e5ee54..9930e357c40b 100644
--- a/science/plumed/Makefile
+++ b/science/plumed/Makefile
@@ -1,6 +1,7 @@
PORTNAME= plumed
DISTVERSIONPREFIX= v
DISTVERSION= 2.8b
+PORTREVISION= 1
CATEGORIES= science graphics
MAINTAINER= yuri@FreeBSD.org
@@ -12,9 +13,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
BROKEN_i386= undefined reference to `__atomic_load'
BUILD_DEPENDS= bash:shells/bash
+LIB_DEPENDS= libblas.so:math/blas \
+ libfftw3.so:math/fftw3 \
+ libgsl.so:math/gsl \
+ liblapack.so:math/lapack
RUN_DEPENDS= bash:shells/bash
+TEST_DEPENDS= gawk:lang/gawk
-USES= autoreconf compiler:c++11-lang gmake pkgconfig shebangfix
+USES= autoreconf compiler:c++11-lang gmake localbase pkgconfig shebangfix
USE_LDCONFIG= yes
SHEBANG_GLOB= *.sh
@@ -31,7 +37,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --disable-python
TEST_TARGET= check # the 'installcheck' target checks installed version
-# 27 tests are known to fail: https://github.com/plumed/plumed2/issues/782
+# 1 test is known to fail: https://github.com/plumed/plumed2/issues/782
+
+BINARY_ALIAS= make=${GMAKE} # only needed for tests
post-patch:
@${REINPLACE_CMD} -e 's|#! /bin/bash|#! ${LOCALBASE}/bin/bash|' ${WRKSRC}/src/lib/Makefile