aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-20 19:10:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-20 19:27:24 +0000
commitf0a0f8d9cc6e62f9afc008dd33286d9758640f7a (patch)
treee8cb45e45b5306d124372a196d17dea7bc486a9e /science
parent3cb48e478564abe85103a46357e7bbb007e542b2 (diff)
downloadports-f0a0f8d9cc6e62f9afc008dd33286d9758640f7a.tar.gz
ports-f0a0f8d9cc6e62f9afc008dd33286d9758640f7a.zip
science/gabedit: Improve BROKEN lines and options
OPENMP option doesn't appear where it is not supported. (cherry picked from commit 704f77e78a9532b153a8863b7d96e30c81e88bcc)
Diffstat (limited to 'science')
-rw-r--r--science/gabedit/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/science/gabedit/Makefile b/science/gabedit/Makefile
index 72ec14c27b70..b75fc5200449 100644
--- a/science/gabedit/Makefile
+++ b/science/gabedit/Makefile
@@ -11,9 +11,10 @@ COMMENT= Graphical user interface for several chemistry software packages
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/License
-BROKEN_armv6= fatal error: 'omp.h' file not found
-BROKEN_armv7= fatal error: 'omp.h' file not found
BROKEN_i386= undefined reference to `__atomic_load'
+.if !exists(/usr/include/omp.h)
+BROKEN= requires OpenMP support that is missing on this architecture
+.endif
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -37,14 +38,9 @@ ICON_SIZES= 16 24 32 48
PLIST_FILES+= share/icons/hicolor/${SZ}x${SZ}/apps/${PORTNAME}.png
.endfor
+.if exists(/usr/include/omp.h)
OPTIONS_DEFINE= OPENMP
OPTIONS_DEFAULT= OPENMP
-OPTIONS_EXCLUDE_powerpc= OPENMP
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1301000
-BROKEN_riscv64= fatal error: 'omp.h' file not found
.endif
post-patch:
@@ -61,4 +57,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/icons/Gabedit${SZ}.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps/${PORTNAME}.png
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>