aboutsummaryrefslogtreecommitdiff
path: root/security/aide/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-02-06 13:17:01 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-02-06 13:17:01 +0000
commit58b7e36a58b05f3db6437bb1956e7df79dab7669 (patch)
tree60b7fbb4ad5da1ca6ab3d5fe7df51bc6ab27d391 /security/aide/Makefile
parentb00f6ee930d8b60f95b348d7cd2e6d780dac33d9 (diff)
downloadports-58b7e36a58b05f3db6437bb1956e7df79dab7669.tar.gz
ports-58b7e36a58b05f3db6437bb1956e7df79dab7669.zip
Misc. port cleanups and some manpage fixes (correct FILES section).
PR: 20997 (slightly modified for new port layout) Submitted by: olgeni Approved by: maintainer
Notes
Notes: svn path=/head/; revision=38035
Diffstat (limited to 'security/aide/Makefile')
-rw-r--r--security/aide/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index cb2dd41569f2..f1e6619d739c 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -27,16 +27,16 @@ MAN1= aide.1
MAN5= aide.conf.5
post-install:
- ${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf.sample
+ @${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf.sample
+ @${MKDIR} /var/adm/aide/databases
+ @if [ ! -f /var/adm/aide/aide.conf ]; then \
+ ${CHOWN} root:wheel /var/adm/aide ; \
+ ${CHOWN} root:wheel /var/adm/aide/databases ; \
+ ${CHMOD} 0700 /var/adm/aide ; \
+ ${CHMOD} 0700 /var/adm/aide/databases ; \
+ fi
@${ECHO}
- @${ECHO} "If you want to finish setting up AIDE, don't forget to make"
- @${ECHO} "a new directory called /var/adm/aide and then create your own"
- @${ECHO} "aide.conf based on ${PREFIX}/etc/aide.conf.sample and then"
- @${ECHO} "copy it to that directory. You will also need to make the"
- @${ECHO} "databases directory, /var/adm/aide/databases, and run the"
- @${ECHO} "following command:"
- @${ECHO}
- @${ECHO} " cd /var/adm/aide;aide --init;mv databases/aide.db.new databases/aide.db"
+ @${CAT} ${PKGMESSAGE}
@${ECHO}
.if defined(AIDE_FLOPPY)
@disklabel -w -B /dev/rfd0c fd1440