aboutsummaryrefslogtreecommitdiff
path: root/security/gnomint/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-02 14:42:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-02 14:42:54 +0000
commit7f08ae7f388ae62b9c14f4e748feb34f7751be8a (patch)
treea10284285dbf475846a4178d43231d9a02f9c4d9 /security/gnomint/Makefile
parent94a665c0e884fbcc327a32840362284fb5634abd (diff)
downloadports-7f08ae7f388ae62b9c14f4e748feb34f7751be8a.tar.gz
ports-7f08ae7f388ae62b9c14f4e748feb34f7751be8a.zip
gnoMint is an X.509 Certificate Authority (CA) management tool with both a GTK
and command-line interface. It allows anyone to create and manage a CA without having to write configuration files or remember long command-line arguments. WWW: http://gnomint.sourceforge.net/ PR: ports/176580 Submitted by: Kevin Zheng <kevinz5000@gmail.com>
Notes
Notes: svn path=/head/; revision=313243
Diffstat (limited to 'security/gnomint/Makefile')
-rw-r--r--security/gnomint/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/gnomint/Makefile b/security/gnomint/Makefile
new file mode 100644
index 000000000000..d779a9528118
--- /dev/null
+++ b/security/gnomint/Makefile
@@ -0,0 +1,38 @@
+# Created by: Kevin Zheng <kevinz5000@gmail.com>
+# $FreeBSD$
+
+PORTNAME= gnomint
+PORTVERSION= 1.2.1
+CATEGORIES= security
+MASTER_SITES= SF
+
+MAINTAINER= kevinz5000@gmail.com
+COMMENT= X.509 Certification Authority management tool
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
+ gnutls:${PORTSDIR}/security/gnutls \
+ sqlite3:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gconf2 gdkpixbuf2 glib20 gtk20
+USE_PERL5= yes
+CFLAGS:= ${CFLAGS:C/-Werror//}
+
+MAKE_JOBS_SAFE= yes
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>