aboutsummaryrefslogtreecommitdiff
path: root/security/nmap/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-04-11 04:52:45 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-04-11 04:52:45 +0000
commitf568cd2d45c25de5aaee139acbaa8699a29c4996 (patch)
tree61b11a78450eb55d0ed03c9e0c2981594672403e /security/nmap/Makefile
parentd12c29cb9606b7e1ada775728faf4e967aefa792 (diff)
downloadports-f568cd2d45c25de5aaee139acbaa8699a29c4996.tar.gz
ports-f568cd2d45c25de5aaee139acbaa8699a29c4996.zip
- update nmap nselib and scripts to upstream revision r32810
The update includes a working script to detect whether a server is vulnerable to the OpenSSL Heartbleed bug (CVE-2014-0160) http://nmap.org/nsedoc/scripts/ssl-heartbleed.html MFH: 2014Q2
Notes
Notes: svn path=/head/; revision=350889
Diffstat (limited to 'security/nmap/Makefile')
-rw-r--r--security/nmap/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 885891a4d9b5..e3510752f393 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -3,11 +3,15 @@
PORTNAME= nmap
DISTVERSION= 6.40
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
+PATCH_SITES= ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= ohauer
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-r${PATCHREV}.diff.bz2
+
MAINTAINER= ohauer@FreeBSD.org
COMMENT= Port scanning utility for large networks
@@ -19,9 +23,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2 dos2unix
GNU_CONFIGURE= yes
+DOS2UNIX_FILES= nselib/data/packetdecoders.lua
+
+# Upstream revision r32810: nselib, scripts
+PATCHREV= 32810
OPTIONS_SUB= yes
OPTIONS_DEFINE= DOCS IPV6 SSL
@@ -70,9 +77,13 @@ pre-patch:
post-configure:
@${REINPLACE_CMD} -e "s|^DESTDIR *=|& ${DESTDIR}|" ${WRKSRC}/Makefile
+pre-install:
+ ${FIND} ${WRKSRC} -type f \( -name \*.orig -o -name \*.bak \) -delete
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
# gcc from ports is in use
.if defined(NDCC)