aboutsummaryrefslogtreecommitdiff
path: root/security/py-python-registry
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-03-26 20:24:12 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-03-26 20:24:12 +0000
commit6748e3b8de25adf9daafa71be98411c7e1a8795d (patch)
tree015c9a731785ee658e479431eee6437399aa5fcb /security/py-python-registry
parent1197b5f40ea08c5e51a57c934ea68a64629cfedb (diff)
downloadports-6748e3b8de25adf9daafa71be98411c7e1a8795d.tar.gz
ports-6748e3b8de25adf9daafa71be98411c7e1a8795d.zip
python-registry was originally written by Willi Ballenthin, a forensicator who
wanted to access the contents of the Windows Registry from his Linux laptop. python-registry currently provides read-only access to Windows Registry files, such as NTUSER.DAT, userdiff, and SOFTWARE. The interface is two-fold: a high-level interface suitable for most tasks, and a low level set of parsing objects and methods which may be used for advanced study of the Windows Registry. python-registry is written in pure Python, making it portable across all major platforms. WWW: http://www.williballenthin.com/registry/ PR: 173141 Submitted by: Antoine Brodin <antoine@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=315323
Diffstat (limited to 'security/py-python-registry')
-rw-r--r--security/py-python-registry/Makefile38
-rw-r--r--security/py-python-registry/distinfo2
-rw-r--r--security/py-python-registry/pkg-descr10
-rw-r--r--security/py-python-registry/pkg-plist23
4 files changed, 73 insertions, 0 deletions
diff --git a/security/py-python-registry/Makefile b/security/py-python-registry/Makefile
new file mode 100644
index 000000000000..3d6213b624a1
--- /dev/null
+++ b/security/py-python-registry/Makefile
@@ -0,0 +1,38 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-registry
+PORTVERSION= 0.2.5
+CATEGORIES= security devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Read access to Windows Registry files
+
+LICENSE= AL2
+
+USE_GITHUB= yes
+GH_ACCOUNT= williballenthin
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 8ea7e05
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|0.2.4.1|${PORTVERSION}|' ${WRKSRC}/Registry/__init__.py
+ ${REINPLACE_CMD} -i '' -e 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/samples/*
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/documentation/* ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/samples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/py-python-registry/distinfo b/security/py-python-registry/distinfo
new file mode 100644
index 000000000000..2bfdab7348ff
--- /dev/null
+++ b/security/py-python-registry/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-registry-0.2.5.tar.gz) = d882fbb5a5608b0ba092362ada3a99753d8b3c184f9811fcbe386a0e708d7faa
+SIZE (python-registry-0.2.5.tar.gz) = 133259
diff --git a/security/py-python-registry/pkg-descr b/security/py-python-registry/pkg-descr
new file mode 100644
index 000000000000..f348d8ce4a61
--- /dev/null
+++ b/security/py-python-registry/pkg-descr
@@ -0,0 +1,10 @@
+python-registry was originally written by Willi Ballenthin, a forensicator who
+wanted to access the contents of the Windows Registry from his Linux laptop.
+python-registry currently provides read-only access to Windows Registry files,
+such as NTUSER.DAT, userdiff, and SOFTWARE. The interface is two-fold: a
+high-level interface suitable for most tasks, and a low level set of parsing
+objects and methods which may be used for advanced study of the Windows
+Registry. python-registry is written in pure Python, making it portable across
+all major platforms.
+
+WWW: http://www.williballenthin.com/registry/
diff --git a/security/py-python-registry/pkg-plist b/security/py-python-registry/pkg-plist
new file mode 100644
index 000000000000..3412cb6e3e80
--- /dev/null
+++ b/security/py-python-registry/pkg-plist
@@ -0,0 +1,23 @@
+%%PYTHON_SITELIBDIR%%/Registry/Registry.py
+%%PYTHON_SITELIBDIR%%/Registry/Registry.pyc
+%%PYTHON_SITELIBDIR%%/Registry/Registry.pyo
+%%PYTHON_SITELIBDIR%%/Registry/RegistryParse.py
+%%PYTHON_SITELIBDIR%%/Registry/RegistryParse.pyc
+%%PYTHON_SITELIBDIR%%/Registry/RegistryParse.pyo
+%%PYTHON_SITELIBDIR%%/Registry/__init__.py
+%%PYTHON_SITELIBDIR%%/Registry/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Registry/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/Registry
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/TheWindowsNTRegistryFileFormat.pdf
+%%PORTDOCS%%%%DOCSDIR%%/WinReg.txt
+%%PORTDOCS%%%%DOCSDIR%%/registry.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/findkey.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/printall.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regfetch.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regview.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shellbags.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shelltypes.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeline.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%