aboutsummaryrefslogtreecommitdiff
path: root/security/sha1collisiondetection
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-07-02 04:00:29 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-07-02 04:00:29 +0000
commitaff42c7199b9182b398eeda522cb9bcb182895f8 (patch)
tree1132ef2f7655593f25dfefe7bd682bbbb7a0d555 /security/sha1collisiondetection
parent83fac84d499abb25f1d93b9cce214a6daeca6e7d (diff)
downloadports-aff42c7199b9182b398eeda522cb9bcb182895f8.tar.gz
ports-aff42c7199b9182b398eeda522cb9bcb182895f8.zip
Mark ports broken on mips64 that are already broken on powerpc64. In
most cases, the failure mode is the same. Also, mark them broken on mips when necessary. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=473699
Diffstat (limited to 'security/sha1collisiondetection')
-rw-r--r--security/sha1collisiondetection/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/sha1collisiondetection/Makefile b/security/sha1collisiondetection/Makefile
index f7574a47793f..d4f3f805bf25 100644
--- a/security/sha1collisiondetection/Makefile
+++ b/security/sha1collisiondetection/Makefile
@@ -14,14 +14,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN_aarch64= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv6= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv7= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
+BROKEN_mips= fails to compile: cc1: unrecognized command line option -std=c90
+BROKEN_mips64= fails to compile: cc1: unrecognized command line option -std=c90
BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option -std=c90
USE_GITHUB= yes
GH_ACCOUNT= cr-marcstevens
-USE_LDCONFIG= yes
-
USES= gmake libtool:build
+USE_LDCONFIG= yes
PLIST_FILES= bin/sha1dcsum \
bin/sha1dcsum_partialcoll \