aboutsummaryrefslogtreecommitdiff
path: root/shells/nushell
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-10-11 06:07:59 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-10-11 18:26:42 +0000
commitbaedfc735ccc88f719573768727b48ce25095818 (patch)
tree694fef026b192972c780f498b6a6f9d26adf6f9a /shells/nushell
parent528cd3d026c76763dd3b250eafe643c2c025d586 (diff)
downloadports-baedfc735ccc88f719573768727b48ce25095818.tar.gz
ports-baedfc735ccc88f719573768727b48ce25095818.zip
shells/nushell: fix build on powerpc
= note: ld: error: undefined symbol: __atomic_load_8
Diffstat (limited to 'shells/nushell')
-rw-r--r--shells/nushell/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/shells/nushell/Makefile b/shells/nushell/Makefile
index be61596d5b7a..0eec6afc5680 100644
--- a/shells/nushell/Makefile
+++ b/shells/nushell/Makefile
@@ -607,6 +607,13 @@ DATAFRAME_DESC= Include the dataframe feature
DATAFRAME_VARS= CARGO_BUILD_ARGS+=--features=dataframe
DATAFRAME_BROKEN= see https://github.com/nushell/nushell/issues/7665
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+LIB_DEPENDS= libatomic.so:lang/gcc${GCC_DEFAULT}
+LDFLAGS= -L/usr/local/lib/gcc${GCC_DEFAULT} -latomic
+.endif
+
.include <bsd.port.pre.mk>
# avoid address space exhaustion in compiler