aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-05 21:00:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-05 21:00:44 +0000
commit05d2ab117deddfd85c6e126c1d45562f97548b74 (patch)
tree9681e29b34f473930701f4538fa4a45c9532783d /shells
parentabeb37f976aa7b0d4ff4e560416e63071c74b5b1 (diff)
downloadports-05d2ab117deddfd85c6e126c1d45562f97548b74.tar.gz
ports-05d2ab117deddfd85c6e126c1d45562f97548b74.zip
a interactive PHP Shell with tab-completion, inline help
and handling of FATAL errors WWW: http://pear.php.net/package/PHP_Shell/
Notes
Notes: svn path=/head/; revision=197141
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/pear-PHP_Shell/Makefile34
-rw-r--r--shells/pear-PHP_Shell/distinfo3
-rw-r--r--shells/pear-PHP_Shell/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 1b49e6444e58..2899ae976551 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -22,6 +22,7 @@
SUBDIR += p5-Term-ShellUI
SUBDIR += pash
SUBDIR += pdksh
+ SUBDIR += pear-PHP_Shell
SUBDIR += perlsh
SUBDIR += rc
SUBDIR += rssh
diff --git a/shells/pear-PHP_Shell/Makefile b/shells/pear-PHP_Shell/Makefile
new file mode 100644
index 000000000000..9c988c3fce66
--- /dev/null
+++ b/shells/pear-PHP_Shell/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: pear-PHP_Shell
+# Date created: 05 August 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHP_Shell
+PORTVERSION= 0.3.0
+CATEGORIES= shells www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A interactive PHP Shell
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+FILES= ShellTests.php PHP/Shell.php \
+ PHP/Shell/Commands.php PHP/Shell/Extensions.php \
+ PHP/Shell/Options.php \
+ PHP/Shell/Extensions/Autoload.php \
+ PHP/Shell/Extensions/AutoloadDebug.php \
+ PHP/Shell/Extensions/Colour.php \
+ PHP/Shell/Extensions/ExecutionTime.php \
+ PHP/Shell/Extensions/InlineHelp.php \
+ PHP/Shell/Extensions/Prototypes.php \
+ PHP/Shell/Extensions/VerbosePrint.php
+EXAMPLES= php-shell-cmd.php
+SCRIPTSFILES= php-shell-cmd.php php-shell.bat \
+ php-shell.sh
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/shells/pear-PHP_Shell/distinfo b/shells/pear-PHP_Shell/distinfo
new file mode 100644
index 000000000000..0f963db858a7
--- /dev/null
+++ b/shells/pear-PHP_Shell/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/PHP_Shell-0.3.0.tgz) = 9812da88473d3952899c8048eca9ff5d
+SHA256 (PEAR/PHP_Shell-0.3.0.tgz) = 4ef5c8930855c4b43094103d85c2fb17e9cf65b8101253792d7a482e05262393
+SIZE (PEAR/PHP_Shell-0.3.0.tgz) = 88961
diff --git a/shells/pear-PHP_Shell/pkg-descr b/shells/pear-PHP_Shell/pkg-descr
new file mode 100644
index 000000000000..c8f62f91df98
--- /dev/null
+++ b/shells/pear-PHP_Shell/pkg-descr
@@ -0,0 +1,4 @@
+a interactive PHP Shell with tab-completion, inline help
+and handling of FATAL errors
+
+WWW: http://pear.php.net/package/PHP_Shell/