aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-01-10 14:20:12 +0000
committerStefan Eßer <se@FreeBSD.org>2022-01-10 15:15:39 +0000
commitbcaf25a8c8046b094f6b5ab5bc258333bc326ee1 (patch)
tree3930596b8cbea97540270b3d78ffb64373c89593 /shells
parentf1661bdbbac2d08cc535e38e41d2bbd3fec025c4 (diff)
downloadports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.tar.gz
ports-bcaf25a8c8046b094f6b5ab5bc258333bc326ee1.zip
Fix CONFLICTS entries of multiple ports
There have been lots of missing CONFLICTS_INSTALL entries, either because conflicting ports were added without updating existing ports, due to name changes of generated packages, due to mis-understanding the format and semantics of the conflicts entries, or just due to typoes in package names. This patch is the result of a comparison of all files contained in the official packages with each other. This comparison was based on packages built with default options and may therefore have missed further conflicts with optionally installed files. Where possible, version numbers in conflicts entries have been generalized, some times taking advantage of the fact that a port cannot conflict with itself (due to logic in bsd.port.mk that supresses the pattern match result in that case). A few ports that set the conflicts variables depending on complex conditions (e.g. port options), have been left unmodified, despite probably containing outdated package names. These changes should only affect the installation of locally built ports, not the package building with poudriere. They should give an early indication of the install conflict in cases where currently the pkg command aborts an installation when it detects that an existing file would be overwritten, Approved by: portmgr (implicit)
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile2
-rw-r--r--shells/heirloom-sh/Makefile3
2 files changed, 5 insertions, 0 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 22bed822d621..34981c2b3d56 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -15,6 +15,8 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
PREFIX="\$$(DESTDIR)${PREFIX}" \
CONFDIR="\$$(DESTDIR)${PREFIX}/etc" \
+CONFLICTS_INSTALL= fd-find # bin/fd
+
DOCS_EN= FAQ.eng \
LICENSES.eng \
README.eng \
diff --git a/shells/heirloom-sh/Makefile b/shells/heirloom-sh/Makefile
index 04a8a214358d..258b0bd0d35d 100644
--- a/shells/heirloom-sh/Makefile
+++ b/shells/heirloom-sh/Makefile
@@ -13,6 +13,9 @@ BROKEN_aarch64= Fails to link: missing sbrk
BROKEN_riscv64= Fails to link: missing sbrk
USES= tar:bzip2
+
+CONFLICTS_INSTALL= clusterit schilyutils # bin/jsh
+
MAKEFILE= makefile
PLIST_FILES= "@shell bin/jsh" \
man/man1/jsh.1.gz