aboutsummaryrefslogtreecommitdiff
path: root/sysutils/devd-mount
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-07-07 14:35:00 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-07-07 14:35:00 +0000
commit67d311c3b7011b8377e7413cd63c32c255a84d0a (patch)
treed11a6a7eb6217d25d7e7d3f42775250735b11fd2 /sysutils/devd-mount
parent32a734d694139190f970dca54ba37f6091841635 (diff)
downloadports-67d311c3b7011b8377e7413cd63c32c255a84d0a.tar.gz
ports-67d311c3b7011b8377e7413cd63c32c255a84d0a.zip
sysutils/devd-mount: Automount tool utilizing devd notifications
devd-mount(8) is a devd(8) based automounter for FreeBSD. It supports most popular filesystems such as exFAT, ISO9660, UDF, and FreeBSD's native UFS. The devd-mount script mounts recognized filesystems and invokes a specified command (typically qmediamanager) with the mount point, device, and filesystem type as optional arguments.
Diffstat (limited to 'sysutils/devd-mount')
-rw-r--r--sysutils/devd-mount/Makefile32
-rw-r--r--sysutils/devd-mount/distinfo3
-rw-r--r--sysutils/devd-mount/pkg-descr5
-rw-r--r--sysutils/devd-mount/pkg-message10
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/devd-mount/Makefile b/sysutils/devd-mount/Makefile
new file mode 100644
index 000000000000..fdf5d02ae5c0
--- /dev/null
+++ b/sysutils/devd-mount/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= devd-mount
+DISTVERSION= 0.1.0-1
+DISTVERSIONSUFFIX= -gd153f96
+CATEGORIES= sysutils
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Automount tool utilizing devd notifications
+WWW= https://github.com/outpaddling/devd-mount
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= outpaddling
+
+NO_BUILD= yes
+
+PLIST_FILES= sbin/devd-mount \
+ etc/devd/devd-mount.conf \
+ "@sample etc/devd-mount.conf.sample" \
+ man/man8/devd-mount.8.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/devd-mount ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/devd.conf \
+ ${STAGEDIR}${PREFIX}/etc/devd/devd-mount.conf
+ ${INSTALL_DATA} ${WRKSRC}/devd-mount.conf \
+ ${STAGEDIR}${PREFIX}/etc/devd-mount.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/Man/devd-mount.8 \
+ ${STAGEDIR}${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/devd-mount/distinfo b/sysutils/devd-mount/distinfo
new file mode 100644
index 000000000000..d740c528b388
--- /dev/null
+++ b/sysutils/devd-mount/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688648299
+SHA256 (outpaddling-devd-mount-0.1.0-1-gd153f96_GH0.tar.gz) = bd1873d02501f62845974e34043422a28451b9f88a7196860bec547ae0b05ffe
+SIZE (outpaddling-devd-mount-0.1.0-1-gd153f96_GH0.tar.gz) = 4820
diff --git a/sysutils/devd-mount/pkg-descr b/sysutils/devd-mount/pkg-descr
new file mode 100644
index 000000000000..013ac3d1a229
--- /dev/null
+++ b/sysutils/devd-mount/pkg-descr
@@ -0,0 +1,5 @@
+devd-mount(8) is a devd(8) based automounter for FreeBSD. It supports
+most popular filesystems such as exFAT, ISO9660, UDF, and FreeBSD's
+native UFS. The devd-mount script mounts recognized filesystems and
+invokes a specified command (typically qmediamanager) with the mount
+point, device, and filesystem type as optional arguments.
diff --git a/sysutils/devd-mount/pkg-message b/sysutils/devd-mount/pkg-message
new file mode 100644
index 000000000000..ff64f36a0c9b
--- /dev/null
+++ b/sysutils/devd-mount/pkg-message
@@ -0,0 +1,10 @@
+[
+{ type: install
+ message: <<EOM
+
+You must restart the devd service to load the devd-mount configuration.
+
+ service devd restart
+EOM
+}
+]