aboutsummaryrefslogtreecommitdiff
path: root/sysutils/slurm-wlm
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-15 01:48:24 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-15 01:48:24 +0000
commit84cd784fee390733f6597c98065c1e94568c0a53 (patch)
tree591e59ce51b9f95515924f92882e4a4414310e3b /sysutils/slurm-wlm
parent7ac5bc470ad4c88b38a691dfdd4706fd03ee3452 (diff)
downloadports-84cd784fee390733f6597c98065c1e94568c0a53.tar.gz
ports-84cd784fee390733f6597c98065c1e94568c0a53.zip
sysutils/slurm-wlm: improve build on hosts with other ports installed
Slurm will try to install different components based on various installed libraries. This patch fixes issues where some files are unexpectedly installed. PR: 209511 Submitted by: Joseph Mingrone <jrm@ftfl.ca> (maintainer)
Notes
Notes: svn path=/head/; revision=415205
Diffstat (limited to 'sysutils/slurm-wlm')
-rw-r--r--sysutils/slurm-wlm/Makefile47
-rw-r--r--sysutils/slurm-wlm/pkg-plist18
2 files changed, 48 insertions, 17 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index f2f506152ea0..2829d7f80504 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -15,11 +15,9 @@ COMMENT= Simple Linux Utility for Resource Management
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libsysinfo.so:devel/libsysinfo \
- libhwloc.so:devel/hwloc \
- libmunge.so:security/munge \
- librrd.so:databases/rrdtool \
- libhdf5.so:science/hdf5
+LIB_DEPENDS= libjson-c.so:devel/json-c \
+ libsysinfo.so:devel/libsysinfo \
+ libmunge.so:security/munge
USERS= slurm
GROUPS= ${USERS}
@@ -29,16 +27,41 @@ USE_LDCONFIG= yes
USE_RC_SUBR= slurmctld slurmd
PLIST_SUB= PORTVERSION="${PORTVERSION}"
INSTALL_TARGET= install-strip
-USES= gmake libtool perl5 pkgconfig python tar:bz2
-GTK2_USE= GNOME=glib20,gtk20
-MYSQL_USE= MYSQL=yes
-CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lsysinfo -lkvm
+USES= gmake libtool pkgconfig python:build tar:bz2
+USE_perl5= configure
-OPTIONS_DEFINE= DOCS MYSQL GTK2
+OPTIONS_DEFINE= CURL DOCS GTK2 HDF5 HWLOC IPMI MYSQL RRD
+OPTIONS_DEFAULT=HDF5 HWLOC
OPTIONS_SUB= yes
-GTK2_DESC= Build GUI config tool sview
+CURL_DESC= Require cURL for elasticsearch plugins
+GTK2_DESC= Build sview GUI config tool
+HDF5_DESC= Job profiling using HDF5
+HWLOC_DESC= Portable hardware locality
+IPMI_DESC= IPMI engergy consumption accounting
+RRD_DESC= RRD external sensor data collection
+
+GTK2_USE= GNOME=glib20,gtk20
+
+CURL_LIB_DEPENDS= libcurl.so:ftp/curl
+CURL_CONFIGURE_with= libcurl
+
+HDF5_LIB_DEPENDS= libhdf5.so:science/hdf5
+HDF5_CONFIGURE_WITH= hdf5
+
+HWLOC_LIB_DEPENDS= libhwloc.so:devel/hwloc
+HWLOC_CONFIGURE_WITH= hwloc
+
+IPMI_LIB_DEPENDS= libfreeipmi.so:sysutils/freeipmi
+IPMI_CONFIGURE_WITH= freeipmi
+
+RRD_LIB_DEPENDS= librrd.so:databases/rrdtool
+RRD_CONFIGURE_WITH= rrdtool
+
+MYSQL_USE= MYSQL=yes
+
+CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lsysinfo -lkvm
# SLURM's configure enables interactive jobs if pty.h exists. Replacing
# #include <pty.h> with appropriate headers will therefore not work, so instead
diff --git a/sysutils/slurm-wlm/pkg-plist b/sysutils/slurm-wlm/pkg-plist
index 6f6144780cbd..78e213f95abc 100644
--- a/sysutils/slurm-wlm/pkg-plist
+++ b/sysutils/slurm-wlm/pkg-plist
@@ -7,7 +7,7 @@ bin/sbcast
bin/scancel
bin/scontrol
bin/sdiag
-bin/sh5util
+%%HDF5%%bin/sh5util
bin/sinfo
bin/smap
bin/sprio
@@ -59,14 +59,20 @@ lib/slurm/acct_gather_filesystem_none.a
lib/slurm/acct_gather_filesystem_none.so
lib/slurm/acct_gather_infiniband_none.a
lib/slurm/acct_gather_infiniband_none.so
-lib/slurm/acct_gather_profile_hdf5.a
-lib/slurm/acct_gather_profile_hdf5.so
+%%IPMI%%lib/slurm/acct_gather_energy_ipmi.a
+%%IPMI%%lib/slurm/acct_gather_energy_ipmi.so
+%%HDF5%%lib/slurm/acct_gather_profile_hdf5.a
+%%HDF5%%lib/slurm/acct_gather_profile_hdf5.so
lib/slurm/acct_gather_profile_none.a
lib/slurm/acct_gather_profile_none.so
lib/slurm/auth_munge.a
lib/slurm/auth_munge.so
lib/slurm/auth_none.a
lib/slurm/auth_none.so
+lib/slurm/burst_buffer_cray.a
+lib/slurm/burst_buffer_cray.so
+lib/slurm/power_cray.a
+lib/slurm/power_cray.so
lib/slurm/burst_buffer_generic.a
lib/slurm/burst_buffer_generic.so
lib/slurm/checkpoint_none.a
@@ -83,8 +89,8 @@ lib/slurm/crypto_openssl.a
lib/slurm/crypto_openssl.so
lib/slurm/ext_sensors_none.a
lib/slurm/ext_sensors_none.so
-lib/slurm/ext_sensors_rrd.a
-lib/slurm/ext_sensors_rrd.so
+%%RRD%%lib/slurm/ext_sensors_rrd.a
+%%RRD%%lib/slurm/ext_sensors_rrd.so
lib/slurm/gres_gpu.a
lib/slurm/gres_gpu.so
lib/slurm/gres_mic.a
@@ -121,6 +127,8 @@ lib/slurm/jobacct_gather_linux.a
lib/slurm/jobacct_gather_linux.so
lib/slurm/jobacct_gather_none.a
lib/slurm/jobacct_gather_none.so
+%%CURL%%lib/slurm/jobcomp_elasticsearch.a
+%%CURL%%lib/slurm/jobcomp_elasticsearch.so
lib/slurm/jobcomp_filetxt.a
lib/slurm/jobcomp_filetxt.so
%%MYSQL%%lib/slurm/jobcomp_mysql.a