aboutsummaryrefslogtreecommitdiff
path: root/textproc/es-mythes/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:49 +0000
commit72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63 (patch)
tree5a38291fea0ecf3734c8329b934dc334c8a9feb8 /textproc/es-mythes/Makefile
parent915dbfaa562e20c8402d3873f8bfbf07899f9f8a (diff)
downloadports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.tar.gz
ports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.zip
*/*mythes: Avoid using %% in Makefile
Use ${DATAIDR} instead of %%DATADIR%%
Diffstat (limited to 'textproc/es-mythes/Makefile ')
-rw-r--r--textproc/es-mythes/Makefile 39
1 files changed, 39 insertions, 0 deletions
diff --git a/textproc/es-mythes/Makefile b/textproc/es-mythes/Makefile
new file mode 100644
index 000000000000..1e1384f47301
--- /dev/null
+++ b/textproc/es-mythes/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= mythes
+PORTVERSION= 20140516
+CATEGORIES= textproc spanish
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= es-
+DISTNAME= OOo2-thes_es_ES-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Spanish thesaurus
+
+LICENSE= LGPL21
+
+PORTSCOUT= skipv:20140531
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USES= tar:bzip2
+
+PLIST_FILES= %%DATADIR%%/th_es_ES_v2.dat \
+ %%DATADIR%%/th_es_ES_v2.idx
+
+ESALIASES= es_AR es_BO es_CL es_CO es_CR es_CU es_DO es_EC es_GT es_HN \
+ es_MX es_NI es_PA es_PE es_PR es_PY es_SV es_US es_UY es_VE
+.for ALIAS in ${ESALIASES}
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_es_ES_v2.dat ${WRKSRC}/th_es_ES_v2.idx ${STAGEDIR}${DATADIR}/
+.for ALIAS in ${ESALIASES}
+ ${LN} -s th_es_ES_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_es_ES_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
+
+.include <bsd.port.mk>