aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-errorhandler
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-22 22:08:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-22 22:08:15 +0000
commitebd38f8e8d020e7f2a834f850ecd420ded1b70f3 (patch)
treeb6ab591351468fad02f721ae81a8e5ab208e8eb4 /textproc/py-errorhandler
parent7f4051b9f677a52b6eb695799327ccf81a76ddd5 (diff)
downloadports-ebd38f8e8d020e7f2a834f850ecd420ded1b70f3.tar.gz
ports-ebd38f8e8d020e7f2a834f850ecd420ded1b70f3.zip
A logging framework handler that tracks when messages above a certain
level have been logged. This is a handler for the python standard logging framework that can be used to tell whether messages have been logged at or above a certain level. This can be useful when wanting to ensure that no errors have been logged before committing data back to a database. WWW: http://pypi.python.org/pypi/errorhandler/1.0.0 PR: ports/137970 Submitted by: Dikshie
Notes
Notes: svn path=/head/; revision=240146
Diffstat (limited to 'textproc/py-errorhandler')
-rw-r--r--textproc/py-errorhandler/Makefile20
-rw-r--r--textproc/py-errorhandler/distinfo3
-rw-r--r--textproc/py-errorhandler/pkg-descr11
-rw-r--r--textproc/py-errorhandler/pkg-plist19
4 files changed, 53 insertions, 0 deletions
diff --git a/textproc/py-errorhandler/Makefile b/textproc/py-errorhandler/Makefile
new file mode 100644
index 000000000000..15bd538012a9
--- /dev/null
+++ b/textproc/py-errorhandler/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: errorhandler
+# Date created: 2009-08-19
+# Whom: Dikshie
+#
+# $FreeBSD$
+#
+
+PORTNAME= errorhandler
+PORTVERSION= 1.0.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dikshie@sfc.wide.ad.jp
+COMMENT= A logging framework handler that tracks when messages above a certain level have been logged.
+
+USE_PYTHON= 2.5-2.6
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/textproc/py-errorhandler/distinfo b/textproc/py-errorhandler/distinfo
new file mode 100644
index 000000000000..39803319847a
--- /dev/null
+++ b/textproc/py-errorhandler/distinfo
@@ -0,0 +1,3 @@
+MD5 (errorhandler-1.0.0.tar.gz) = 7d182386011f22ee5d85de9f3544773c
+SHA256 (errorhandler-1.0.0.tar.gz) = 895ba61dc3d563d6df1e3da2ea3f11a3a6395f163ea286e1e91f4aa467f7ae9d
+SIZE (errorhandler-1.0.0.tar.gz) = 5584
diff --git a/textproc/py-errorhandler/pkg-descr b/textproc/py-errorhandler/pkg-descr
new file mode 100644
index 000000000000..c072805e715f
--- /dev/null
+++ b/textproc/py-errorhandler/pkg-descr
@@ -0,0 +1,11 @@
+A logging framework handler that tracks when messages above a certain
+level have been logged.
+
+This is a handler for the python standard logging framework that can
+be used to tell whether messages have been logged at or above a certain
+level.
+
+This can be useful when wanting to ensure that no errors have been
+logged before committing data back to a database.
+
+WWW: http://pypi.python.org/pypi/errorhandler/1.0.0
diff --git a/textproc/py-errorhandler/pkg-plist b/textproc/py-errorhandler/pkg-plist
new file mode 100644
index 000000000000..7155ba6bc769
--- /dev/null
+++ b/textproc/py-errorhandler/pkg-plist
@@ -0,0 +1,19 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/license.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/readme.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/tests.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/tests.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/tests.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler/version.txt
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/errorhandler
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+@dirrm %%PYTHON_SITELIBDIR%%
+@dirrm %%PYTHON_LIBDIR%%