aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-sphinxext-opengraph
diff options
context:
space:
mode:
authorAlexis Praga <alexis.praga@free.fr>2021-08-23 16:30:22 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-08-23 17:27:57 +0000
commit1946f8224cbf10898d3fc0599e6e2ac6c2537c16 (patch)
treed0521e7cf7caded486a63d0b8740cec6a1f12d4d /textproc/py-sphinxext-opengraph
parent2e559ca48c93b075905245367e11e30b9be34b2c (diff)
downloadports-1946f8224cbf10898d3fc0599e6e2ac6c2537c16.tar.gz
ports-1946f8224cbf10898d3fc0599e6e2ac6c2537c16.zip
textproc/py-sphinxext-opengraph: new port
Sphinx extension to generate OpenGraph metadata The Open Graph protocol enables any web page to become a rich object in a social graph This port is a dependency of the new version of x11/kitty (PR 257438) PR: 257436 Reported by: alexis.praga@free.fr Reviewed by: koobs@
Diffstat (limited to 'textproc/py-sphinxext-opengraph')
-rw-r--r--textproc/py-sphinxext-opengraph/Makefile28
-rw-r--r--textproc/py-sphinxext-opengraph/distinfo3
-rw-r--r--textproc/py-sphinxext-opengraph/pkg-descr6
3 files changed, 37 insertions, 0 deletions
diff --git a/textproc/py-sphinxext-opengraph/Makefile b/textproc/py-sphinxext-opengraph/Makefile
new file mode 100644
index 000000000000..eebd3e1b9686
--- /dev/null
+++ b/textproc/py-sphinxext-opengraph/Makefile
@@ -0,0 +1,28 @@
+# Created by: Alexis Praga <alexis.praga@free.fr>
+
+PORTNAME= sphinxext-opengraph
+PORTVERSION= 0.4.2
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexis.praga@free.fr
+COMMENT= Sphinx extension to generate OpenGraph metadata
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=2.0:textproc/py-sphinx@${PY_FLAVOR}
+
+USES= python:3.6+
+# LICENSE and tests are not packaged yet, using github as a fallback
+USE_GITHUB= yes
+GH_ACCOUNT= wpilibsuite
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC}/ && ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
+.include <bsd.port.mk>
diff --git a/textproc/py-sphinxext-opengraph/distinfo b/textproc/py-sphinxext-opengraph/distinfo
new file mode 100644
index 000000000000..7700775e1cf0
--- /dev/null
+++ b/textproc/py-sphinxext-opengraph/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627569745
+SHA256 (wpilibsuite-sphinxext-opengraph-v0.4.2_GH0.tar.gz) = d91d51c932d47e8c2ce657be5934a660daadb19eb9b6240172550f9810e0b404
+SIZE (wpilibsuite-sphinxext-opengraph-v0.4.2_GH0.tar.gz) = 13251
diff --git a/textproc/py-sphinxext-opengraph/pkg-descr b/textproc/py-sphinxext-opengraph/pkg-descr
new file mode 100644
index 000000000000..5d82ad3a29ff
--- /dev/null
+++ b/textproc/py-sphinxext-opengraph/pkg-descr
@@ -0,0 +1,6 @@
+This Sphinx extension allows you to generate OpenGraph metadata.
+
+The Open Graph protocol enables any web page to become a rich object
+in a social graph (see https://ogp.me/).
+
+WWW: https://github.com/wpilibsuite/sphinxext-opengraph