aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-09-15 12:27:30 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-09-15 12:27:30 +0000
commit2d9b5a640b61146297285b94093ac6e62d7c238d (patch)
tree72429f7830052f2a851cc4d2b985d9f8ef191f1c /textproc
parent413b2a3af36f5de7dc6700bed846912d51bffe4c (diff)
downloadports-2d9b5a640b61146297285b94093ac6e62d7c238d.tar.gz
ports-2d9b5a640b61146297285b94093ac6e62d7c238d.zip
Add an explicit dependency on pkgconf
Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=327338
Diffstat (limited to 'textproc')
-rw-r--r--textproc/scim-bridge-qt4/Makefile9
-rw-r--r--textproc/scim-bridge-qt4/pkg-descr2
-rw-r--r--textproc/scim-input-pad/Makefile2
-rw-r--r--textproc/scim-kmfl-imengine/Makefile8
-rw-r--r--textproc/scim-m17n/Makefile11
5 files changed, 9 insertions, 23 deletions
diff --git a/textproc/scim-bridge-qt4/Makefile b/textproc/scim-bridge-qt4/Makefile
index 9adafadf7719..280e41c2dde8 100644
--- a/textproc/scim-bridge-qt4/Makefile
+++ b/textproc/scim-bridge-qt4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scim-bridge-qt4
-# Date created: 2008-08-17
-# Whom: Henry Hu <henry.hu.sh@gmail.com>
-#
+# Created by: Henry Hu <henry.hu.sh@gmail.com>
# $FreeBSD$
-#
PORTNAME= scim-bridge
PORTVERSION= 0.4.16
@@ -19,8 +15,7 @@ RUN_DEPENDS= scim-bridge:${PORTSDIR}/textproc/scim-bridge
USE_QT4= corelib gui moc_build
QT_NONSTANDARD= yes
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
LICENSE= GPLv2 LGPL21
diff --git a/textproc/scim-bridge-qt4/pkg-descr b/textproc/scim-bridge-qt4/pkg-descr
index 0a4d7622fbe4..5d71cc579730 100644
--- a/textproc/scim-bridge-qt4/pkg-descr
+++ b/textproc/scim-bridge-qt4/pkg-descr
@@ -4,4 +4,4 @@ the IME server which communicates with SCIM. The clients are IMModules
which communicate only with the agent so that there is no binary
dependency between the clients and SCIM.
-WWW: http://www.scim-im.org/projects/scim_bridge/
+WWW: http://www.scim-im.org/projects/scim_bridge/
diff --git a/textproc/scim-input-pad/Makefile b/textproc/scim-input-pad/Makefile
index f32d69eafd29..dd9a94e0f7d4 100644
--- a/textproc/scim-input-pad/Makefile
+++ b/textproc/scim-input-pad/Makefile
@@ -14,7 +14,7 @@ COMMENT= SCIM add-on to input various symbols with customisable on-screen pad
LIB_DEPENDS= scim-1.0.10:${PORTSDIR}/textproc/scim
USE_LDCONFIG= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/scim-kmfl-imengine/Makefile b/textproc/scim-kmfl-imengine/Makefile
index c530e8c9f6b0..fe57411b10c9 100644
--- a/textproc/scim-kmfl-imengine/Makefile
+++ b/textproc/scim-kmfl-imengine/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scim-kmfl-imengine
-# Date created: 10 October 2007
-# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
-#
+# Created by: Nikola Lecic <nikola.lecic@anthesphoria.net>
# $FreeBSD$
-#
PORTNAME= scim-kmfl-imengine
PORTVERSION= 0.9.9
@@ -28,7 +24,7 @@ RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
USE_XORG= x11 xkbfile xproto
USE_AUTOTOOLS= libtool
USE_GNOME= glib20 gtk20 intlhack
-USES= gettext iconv
+USES= gettext iconv pkgconfig
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/scim-m17n/Makefile b/textproc/scim-m17n/Makefile
index 3335b0caa554..b7425d3c2d81 100644
--- a/textproc/scim-m17n/Makefile
+++ b/textproc/scim-m17n/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scim-m17n
-# Date Created: 10 May 2007
-# Whom: Yinghong Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= scim-m17n
PORTVERSION= 0.2.3
@@ -12,16 +8,15 @@ CATEGORIES= textproc
MASTER_SITES= SF/scim/${PORTNAME}/${PORTVERSION} \
http://anthesphoria.net/FreeBSD/ports/distfiles/
-
MAINTAINER= nikola.lecic@anthesphoria.net
-COMMENT= A SCIM IMEngine module which uses m17n library as the backend
+COMMENT= SCIM IMEngine module which uses m17n library as the backend
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
gsed:${PORTSDIR}/textproc/gsed
LIB_DEPENDS= m17n.4:${PORTSDIR}/devel/m17n-lib
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
.include <bsd.port.mk>