aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:21:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:21:46 +0000
commitb448c924112a2914f0569c0bcec9690b9fa159cd (patch)
tree69d410f5d69f08b523a59ea57e83f8424e28807e /textproc
parentcc82ac7af1a4b4743ab599432b8c7f24a774e0c8 (diff)
downloadports-b448c924112a2914f0569c0bcec9690b9fa159cd.tar.gz
ports-b448c924112a2914f0569c0bcec9690b9fa159cd.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200793
Diffstat (limited to 'textproc')
-rw-r--r--textproc/estraier/Makefile2
-rw-r--r--textproc/heirloom-doctools/Makefile4
-rw-r--r--textproc/highlight/Makefile8
-rw-r--r--textproc/htdig/Makefile4
-rw-r--r--textproc/libebml/Makefile8
-rw-r--r--textproc/libxml++/Makefile13
-rw-r--r--textproc/nltk/Makefile8
-rw-r--r--textproc/uim/Makefile4
8 files changed, 5 insertions, 46 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index ba1f28f7a8a3..2eb4625a32f7 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -41,13 +41,11 @@ LIB_DEPENDS+= chasen.0:${PORTSDIR}/japanese/chasen-base
CONFIGURE_ARGS+= --enable-chasen
.endif
-.if ${OSVERSION} > 500000
.if ${ARCH} == i386 && defined(WITH_MECAB)
LIB_DEPENDS+= mecab.1:${PORTSDIR}/japanese/mecab
CONFIGURE_ARGS+= --enable-mecab
.endif
-.endif
.if !defined(WITHOUT_KAKASI)
LIB_DEPENDS+= kakasi.3:${PORTSDIR}/japanese/kakasi
diff --git a/textproc/heirloom-doctools/Makefile b/textproc/heirloom-doctools/Makefile
index 94e90961f973..d2fa2d68944d 100644
--- a/textproc/heirloom-doctools/Makefile
+++ b/textproc/heirloom-doctools/Makefile
@@ -58,9 +58,7 @@ DOCS= CHANGES FONTS NEWS PDFS README \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= Does not compile on FreeBSD 4.x
-.elif ${OSVERSION} < 600000
+.if ${OSVERSION} < 600000
BROKEN= fails to install on FreeBSD 5.x
.endif
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
index 2dbec4117714..c0dc29336ea3 100644
--- a/textproc/highlight/Makefile
+++ b/textproc/highlight/Makefile
@@ -34,12 +34,6 @@ MANCOMPRESSED= yes
PORTDOCS= *
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/etc/highlight|${DATADIR}|g' ${WRKSRC}/datadir.cpp
@@ -77,4 +71,4 @@ post-install:
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index 8836f9a28b62..af7feb508ff8 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -46,10 +46,6 @@ CONFIGURE_ARGS+= --with-apache=${LOCALBASE}/sbin
RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${APACHE_PORT}
.endif
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${PATCHDIR}/RELENG_4-patch-htnet_SSLConnection.cc
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
diff --git a/textproc/libebml/Makefile b/textproc/libebml/Makefile
index 298881388f5c..f9b671f3860e 100644
--- a/textproc/libebml/Makefile
+++ b/textproc/libebml/Makefile
@@ -37,10 +37,4 @@ do-configure:
s,^(INSTALL_OPTS_LIB|INSTALL_OPTS)[[:space:]]*=.*$$,\1=${INSTALL_DATA},' \
${WRKSRC}/make/linux/Makefile
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-CFLAGS+= -DNO_WSTRING
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/libxml++/Makefile b/textproc/libxml++/Makefile
index dff8bc43b43b..96246017a733 100644
--- a/textproc/libxml++/Makefile
+++ b/textproc/libxml++/Makefile
@@ -21,15 +21,4 @@ USE_GNOME= gnomehack gnometarget libxml2 pkgconfig
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-post-patch:
- @${FIND} ${WRKSRC}/libxml++ -name *.h \
- | ${XARGS} ${REINPLACE_CMD} \
- -e 's|<istream>|<iostream>|' \
- -e 's|<ostream>|<iostream>|'
-
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/nltk/Makefile b/textproc/nltk/Makefile
index 0fe692b8beab..4c30ee245ceb 100644
--- a/textproc/nltk/Makefile
+++ b/textproc/nltk/Makefile
@@ -19,16 +19,10 @@ USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
USE_PYTHON_PREFIX= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
post-install:
@${FIND} ${PYTHON_SITELIBDIR}/nltk ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${PYTHON_SITELIBDIR}/nltk -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 3b2566373776..5aeb268b249b 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -59,10 +59,6 @@ PLIST_SUB+= X11=""
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-uim_editline.c
-.endif
-
.for _x in x xft gtk2 qt gnome2 anthy canna m17nlib prime scim dict
.if ${CONFIGURE_ARGS:M--with-${_x}} == ""
CONFIGURE_ARGS+=--without-${_x}