aboutsummaryrefslogtreecommitdiff
path: root/www/librtcdcpp/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-10 01:29:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-10 01:29:13 +0000
commitd4ae43bf69ca4926585b3a8fd28e6795898394cd (patch)
tree336c820474f57c4b339a84d234a977deeecaa0d7 /www/librtcdcpp/Makefile
parentca9b65b8114b85f56a5aae31d2678accaa14f52e (diff)
downloadports-d4ae43bf69ca4926585b3a8fd28e6795898394cd.tar.gz
ports-d4ae43bf69ca4926585b3a8fd28e6795898394cd.zip
New port: www/librtcdcpp: Simple WebRTC DataChannels library
Notes
Notes: svn path=/head/; revision=531279
Diffstat (limited to 'www/librtcdcpp/Makefile')
-rw-r--r--www/librtcdcpp/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/librtcdcpp/Makefile b/www/librtcdcpp/Makefile
new file mode 100644
index 000000000000..8857968eabe3
--- /dev/null
+++ b/www/librtcdcpp/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= librtcdcpp
+DISTVERSION= g20180627
+CATEGORIES= www devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simple WebRTC DataChannels library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= spdlog>0:devel/spdlog
+LIB_DEPENDS= libnice.so:net-im/libnice \
+ libusrsctp.so:net/libusrsctp
+
+USES= cmake compiler:c++14-lang gnome ssl
+USE_GITHUB= yes
+GH_ACCOUNT= chadnickbok
+GH_TAGNAME= 49ddb949ed5dd2c8e859097b6723347f52e01645
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+CFLAGS+= -DSPDLOG_FMT_EXTERNAL
+
+do-install:
+ cd ${WRKSRC}/include && ${COPYTREE_SHARE} rtcdcpp ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/librtcdcpp.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>