aboutsummaryrefslogtreecommitdiff
path: root/www/obhttpd/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-29 14:22:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-29 14:22:47 +0000
commit61155ffd860633fbcdbb8d25dba50b3342e7ee21 (patch)
treee5b127ee6a72d6825c3281907d700d1adf36dc47 /www/obhttpd/Makefile
parent91ca14e1fa860a43e4f4e5cedc58900af28c2840 (diff)
downloadports-61155ffd860633fbcdbb8d25dba50b3342e7ee21.tar.gz
ports-61155ffd860633fbcdbb8d25dba50b3342e7ee21.zip
Remove all usage of OPENSSL_PORT from ports, this is deprecated, and
always was a user defined variable. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=417767
Diffstat (limited to 'www/obhttpd/Makefile')
-rw-r--r--www/obhttpd/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/obhttpd/Makefile b/www/obhttpd/Makefile
index 16075e04fc58..5af8a7238e77 100644
--- a/www/obhttpd/Makefile
+++ b/www/obhttpd/Makefile
@@ -20,7 +20,6 @@ USE_RC_SUBR= obhttpd
USES= uidfix
WITH_OPENSSL_PORT=yes
-OPENSSL_PORT= security/libressl
CFLAGS+= -Wall
@@ -48,4 +47,10 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${GH_PROJECT}-${PORTVERSION}/src/etc/examples/httpd.conf \
${STAGEDIR}${PREFIX}/etc/obhttpd.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(SSL_DEFAULT:Mlibressl*)
+IGNORE= Need LibreSSL to build. set DEFAULT_VERSIONS+=ssl=libressl and rebuild everything.
+.endif
+
+.include <bsd.port.post.mk>