aboutsummaryrefslogtreecommitdiff
path: root/www/obhttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/obhttpd/Makefile')
-rw-r--r--www/obhttpd/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/obhttpd/Makefile b/www/obhttpd/Makefile
index 16075e04fc58..5af8a7238e77 100644
--- a/www/obhttpd/Makefile
+++ b/www/obhttpd/Makefile
@@ -20,7 +20,6 @@ USE_RC_SUBR= obhttpd
USES= uidfix
WITH_OPENSSL_PORT=yes
-OPENSSL_PORT= security/libressl
CFLAGS+= -Wall
@@ -48,4 +47,10 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${GH_PROJECT}-${PORTVERSION}/src/etc/examples/httpd.conf \
${STAGEDIR}${PREFIX}/etc/obhttpd.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(SSL_DEFAULT:Mlibressl*)
+IGNORE= Need LibreSSL to build. set DEFAULT_VERSIONS+=ssl=libressl and rebuild everything.
+.endif
+
+.include <bsd.port.post.mk>