aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Escape/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:39:10 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:39:10 +0000
commitaac8eba91dd9eb57bdccab6a3d0441a7e975eb29 (patch)
tree18e75cea224763a0f8e9d4acf8d0eec4dbe191a2 /www/p5-HTML-Escape/Makefile
parentd94a3db6161308a6b4f44b0f9380328f40d83266 (diff)
downloadports-aac8eba91dd9eb57bdccab6a3d0441a7e975eb29.tar.gz
ports-aac8eba91dd9eb57bdccab6a3d0441a7e975eb29.zip
www/p5-HTML-Escape: Add p5-HTML-Escape 1.11
HTML::Escape provides a function which escapes HTML's special characters. It performs a similar function to PHP's htmlspecialchars. It escapes the following characters: " & ' < > ` { } WWW: https://metacpan.org/dist/HTML-Escape
Diffstat (limited to 'www/p5-HTML-Escape/Makefile')
-rw-r--r--www/p5-HTML-Escape/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/p5-HTML-Escape/Makefile b/www/p5-HTML-Escape/Makefile
new file mode 100644
index 000000000000..3b7fa4bd1e70
--- /dev/null
+++ b/www/p5-HTML-Escape/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= HTML-Escape
+PORTVERSION= 1.11
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Extremely fast HTML escaping
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= p5-Test-Requires>=0:devel/p5-Test-Requires
+
+USES= perl5
+USE_PERL5= modbuild
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/HTML/Escape/Escape.so
+
+.include <bsd.port.mk>