aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Escape/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-HTML-Escape/Makefile')
-rw-r--r--www/p5-HTML-Escape/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/p5-HTML-Escape/Makefile b/www/p5-HTML-Escape/Makefile
new file mode 100644
index 000000000000..3b7fa4bd1e70
--- /dev/null
+++ b/www/p5-HTML-Escape/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= HTML-Escape
+PORTVERSION= 1.11
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Extremely fast HTML escaping
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= p5-Test-Requires>=0:devel/p5-Test-Requires
+
+USES= perl5
+USE_PERL5= modbuild
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/HTML/Escape/Escape.so
+
+.include <bsd.port.mk>