aboutsummaryrefslogtreecommitdiff
path: root/www/py-boto3/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-08-06 13:21:16 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-08-06 13:21:16 +0000
commitd7b8873cd76551f70af43d1e3d2982342fbe9c5d (patch)
tree77608802d83d64e6de43b0d9f5159d66f73f444b /www/py-boto3/Makefile
parenta1070ae3174601246150ff32054c23788074f8e3 (diff)
downloadports-d7b8873cd76551f70af43d1e3d2982342fbe9c5d.tar.gz
ports-d7b8873cd76551f70af43d1e3d2982342fbe9c5d.zip
[NEW] www/py-boto3: AWS SDK for Python
Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for Python, which allows Python developers to write software that makes use of services like Amazon S3 and Amazon EC2. You can find the latest, most up to date, documentation at Read the Docs, including a list of services that are supported. WWW: https://github.com/boto/boto3
Notes
Notes: svn path=/head/; revision=419745
Diffstat (limited to 'www/py-boto3/Makefile')
-rw-r--r--www/py-boto3/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/py-boto3/Makefile b/www/py-boto3/Makefile
new file mode 100644
index 000000000000..9db0978af1c1
--- /dev/null
+++ b/www/py-boto3/Makefile
@@ -0,0 +1,36 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= boto3
+PORTVERSION= 1.4.0
+CATEGORIES= www python devel
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= AWS SDK for Python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.4.1:devel/py-botocore \
+ ${PYTHON_PKGNAMEPREFIX}jmespath>=0.7.1:devel/py-jmespath \
+ ${PYTHON_PKGNAMEPREFIX}s3transfer>=0.1.0:net/py-s3transfer
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
+
+# Actually -2.7,3.3-3.5
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= boto
+
+NO_ARCH= yes
+
+# setup.py test runs integration tests which fail
+# https://github.com/boto/s3transfer/issues/41
+# Note: this is an AWS python package wide issue
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v tests/unit tests/functional
+
+.include <bsd.port.mk>