aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-20 07:39:26 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-20 07:39:26 +0000
commitfd24afcf7794cce231dc3feaec39856d4c6b29dc (patch)
tree0b6364db91e60b3752df1af593ad1c7b1f62bac4 /www/seamonkey2
parent5f16a2be6d5cb4dc9c2c91172e7b46747da8b35a (diff)
downloadports-fd24afcf7794cce231dc3feaec39856d4c6b29dc.tar.gz
ports-fd24afcf7794cce231dc3feaec39856d4c6b29dc.zip
Update to 1.7.b
* Re-add OPTIONS support reorganizing the Makefile some * Enable Kerberos/GSSAPI support (please test) * Enable optional smb:// URI support through gnomevfs2 For a list of all the changes in 1.7 beta, please see: http://www.mozilla.org/releases/mozilla1.7b/README.html#new
Notes
Notes: svn path=/head/; revision=104709
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile131
-rw-r--r--www/seamonkey2/distinfo6
-rw-r--r--www/seamonkey2/files/patch-config_autoconf.mk.in14
-rw-r--r--www/seamonkey2/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h30
-rw-r--r--www/seamonkey2/files/patch-nsprpub-pr-src-io-prprf.c14
-rw-r--r--www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in11
-rw-r--r--www/seamonkey2/files/patch-qt61
-rw-r--r--www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk4
-rw-r--r--www/seamonkey2/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc10
9 files changed, 146 insertions, 135 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index c309c93d1015..ba2a734903f3 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.7.a
-PORTREVISION?= 2
+PORTVERSION= 1.7.b
+PORTREVISION?= 0
PORTEPOCH?= 2
CATEGORIES?= www
-MASTER_SITES= ${MASTER_SITE_MOZILLA}
-MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.a/a/}/src
-DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.a/a/}${EXTRACT_SUFX}
+MASTER_SITES= ${MASTER_SITE_MOZILLA} \
+ ${MASTER_SITE_LOCAL:S/$/:local/}
+MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.b/b/}/src \
+ marcus/:local
+DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.b/b/}-source${EXTRACT_SUFX} \
+ libart_lgpl-moz-2.3.10${EXTRACT_SUFX}:local
MAINTAINER= gnome@FreeBSD.org
COMMENT= The open source, standards compliant web browser
@@ -31,25 +34,12 @@ MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
.if defined(WITH_GTK1)
-PKGNAMESUFFIX= -gtk1
+PKGNAMESUFFIX= -gtk
USE_GNOME= gtk12 orbit
.else
USE_GNOME= gtk20 libidl
.endif
-.if !defined(WITHOUT_XFT)
-LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
-.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package.
-.endif
-.endif
-
-.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
- defined(WITHOUT_COMPOSER))
-BROKEN= "Calendar requires Composer and Mailnews support."
-.endif
-
LATEST_LINK= ${MOZILLA}
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -62,6 +52,7 @@ USE_X_PREFIX= yes
USE_PERL5= yes
USE_ICONV= yes
USE_GMAKE= yes
+WANT_GNOME= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
@@ -92,9 +83,61 @@ CONFIGURE_ARGS= \
--with-system-jpeg=${LOCALBASE} \
--with-system-mng=${LOCALBASE} \
--with-system-png=${LOCALBASE} \
+ --with-gssapi=/usr \
--with-pthreads
-PLIST= ${WRKDIR}/pkg-plist
+PLIST= ${WRKDIR}/pkg-plist
+MOZ_EXTENSIONS= default
+CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
+ LOCALBASE=${LOCALBASE}
+
+.if defined(WITH_GTK1)
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
+.endif
+
+ESD_LIB= libesd.so.2
+FREETYPE_LIB= libfreetype.so.9
+PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
+ mozilla-nspr mozilla-nss mozilla-plugin
+
+# JPI stuff. List paths to Java Plug-ins here in the order to try.
+JPI_LIST?=\
+ ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
+
+OPTIONS=XFT "Enable Xft font anti-aliasing" on \
+ CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
+ COMPOSER "Enable the HTML Composer module" on \
+ LDAP "Enable LDAP support for Mailnews" on \
+ CHATZILLA "Enable the Chatzilla IRC module" on \
+ XMLTERM "Enable the XMLTerm module" on \
+ JAVASCRIPT_DEBUGGER "Enable the DTD and JavaScript debuggers" off \
+ OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
+ SMB "Enable smb:// URI support using gnomevfs" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XFT)
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+=--enable-xft
+.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
+BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package.
+.endif
+.else
+CONFIGURE_ARGS+=--disable-xft
+.endif
+
+.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+ defined(WITHOUT_COMPOSER))
+BROKEN= "Calendar requires Composer and Mailnews support."
+.endif
+
# LDAP is only used by mail and news so disable both together
.if defined(WITHOUT_MAILNEWS)
CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
@@ -106,7 +149,6 @@ CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
.endif
.endif
-MOZ_EXTENSIONS= default
.if !defined(WITHOUT_CHATZILLA)
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
.endif
@@ -114,8 +156,6 @@ MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
-CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
- LOCALBASE=${LOCALBASE}
.if defined(WITH_JAVASCRIPT_DEBUGGER)
CONFIGURE_ARGS+= --enable-jsd \
@@ -133,32 +173,6 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK1)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk
-.else
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.endif
-
-.if !defined(WITHOUT_XFT)
-CONFIGURE_ARGS+= --enable-xft
-.else
-CONFIGURE_ARGS+= --disable-xft
-.endif
-
-ESD_LIB= libesd.so.2
-FREETYPE_LIB= libfreetype.so.9
-PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
- mozilla-nspr mozilla-nss mozilla-plugin
-
-# JPI stuff. List paths to Java Plug-ins here in the order to try.
-JPI_LIST?=\
- ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
- ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
- ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
- ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
-
-.include <bsd.port.pre.mk>
-
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
@@ -171,6 +185,13 @@ CONFIGURE_ARGS+= --enable-reorder
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
.endif
+.if defined(WITH_SMB)
+USE_GNOME+= gnomevfs2
+RUN_DEPENDS+= ${X11BASE}/lib/gnome-vfs-2.0/modules/libsmb.so:${PORTSDIR}/devel/gnomevfs-extras
+.else
+CONFIGURE_ARGS+=--disable-gnomevfs
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O2
CONFIGURE_ARGS+= --enable-optimize=-O2
@@ -185,18 +206,6 @@ BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installi
.endif
pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Mozilla has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_XFT=yes Disables Xft anti-aliasing support"
- @${ECHO_MSG} " WITH_CALENDAR=yes Enables the Calendar module (requires Mailnews and Composer modules)"
- @${ECHO_MSG} " WITHOUT_MAILNEWS=yes Disables the Mail and News modules"
- @${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
- @${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
- @${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
- @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
- @${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
- @${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
- @${ECHO_MSG} ""
.if defined(WITH_CALENDAR)
@${ECHO_MSG} ""
@${ECHO_MSG} "Calendar is still beta software."
diff --git a/www/seamonkey2/distinfo b/www/seamonkey2/distinfo
index de32eb39d73b..95c21a25824f 100644
--- a/www/seamonkey2/distinfo
+++ b/www/seamonkey2/distinfo
@@ -1,2 +1,4 @@
-MD5 (mozilla-source-1.7a.tar.bz2) = 6ae50cc951fc112758d5c5dc6b4c3081
-SIZE (mozilla-source-1.7a.tar.bz2) = 32671397
+MD5 (mozilla-source-1.7b-source.tar.bz2) = ee564ecbc7f443f9e49eca1d9ff57296
+SIZE (mozilla-source-1.7b-source.tar.bz2) = 32081692
+MD5 (libart_lgpl-moz-2.3.10.tar.bz2) = a3747d70ba1fff09285d1b23679d0903
+SIZE (libart_lgpl-moz-2.3.10.tar.bz2) = 102847
diff --git a/www/seamonkey2/files/patch-config_autoconf.mk.in b/www/seamonkey2/files/patch-config_autoconf.mk.in
index c119b0c2c6a8..9c7c471bec3c 100644
--- a/www/seamonkey2/files/patch-config_autoconf.mk.in
+++ b/www/seamonkey2/files/patch-config_autoconf.mk.in
@@ -1,18 +1,18 @@
---- config/autoconf.mk.in.orig Sun Nov 17 14:47:49 2002
-+++ config/autoconf.mk.in Sun Nov 17 14:48:17 2002
-@@ -30,13 +30,13 @@
+--- config/autoconf.mk.in.orig Mon Mar 15 22:56:25 2004
++++ config/autoconf.mk.in Fri Mar 19 15:17:50 2004
+@@ -31,13 +31,13 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
--includedir = @includedir@/mozilla-$(MOZILLA_VERSION)
+-includedir = @includedir@/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+includedir = @includedir@/mozilla%%HEADERS_SUFX%%
libdir = @libdir@
datadir = @datadir@
mandir = @mandir@
- idldir = @datadir@/idl/mozilla-$(MOZILLA_VERSION)
+ idldir = @datadir@/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--mozappdir = $(libdir)/mozilla-$(MOZILLA_VERSION)
+-mozappdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+mozappdir = $(libdir)/%%MOZILLA%%
- mredir = $(libdir)/mre/mre-$(MOZILLA_VERSION)
+ mredir = $(libdir)/mre/mre-$(MOZ_APP_VERSION)
mrelibdir = $(mredir)/lib
diff --git a/www/seamonkey2/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h b/www/seamonkey2/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
deleted file mode 100644
index edc10f32f824..000000000000
--- a/www/seamonkey2/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- directory/c-sdk/ldap/libraries/liblber/lber-int.h Tue Mar 26 13:53:23 2002
-+++ directory/c-sdk/ldap/libraries/liblber/lber-int.h Sat Dec 13 13:02:49 2003
-@@ -236,15 +236,15 @@
- (((_l)&0xff0000)>>8) + (((_l)&0xff000000)>>24))
- #define LBER_NTOHL(_l) LBER_HTONL(_l)
-
--#elif !defined(__alpha) || defined(VMS)
-+#elif !defined(__amd64__) && (!defined(__alpha) || defined(VMS))
-
- #define LBER_HTONL( l ) htonl( l )
- #define LBER_NTOHL( l ) ntohl( l )
-
- #else /* __alpha */
- /*
-- * htonl and ntohl on the DEC Alpha under OSF 1 seem to only swap the
-- * lower-order 32-bits of a (64-bit) long, so we define correct versions
-+ * htonl and ntohl on the 64 bit UNIX platforms only swap the lower-order
-+ * 32-bits of a (64-bit) long, so we define correct versions
- * here.
- */
- #define LBER_HTONL( l ) (((long)htonl( (l) & 0x00000000FFFFFFFF )) << 32 \
-@@ -252,7 +252,7 @@
-
- #define LBER_NTOHL( l ) (((long)ntohl( (l) & 0x00000000FFFFFFFF )) << 32 \
- | ntohl( ( (l) & 0xFFFFFFFF00000000 ) >> 32 ))
--#endif /* __alpha */
-+#endif /* __alpha || __amd64__ */
-
-
- /* function prototypes */
diff --git a/www/seamonkey2/files/patch-nsprpub-pr-src-io-prprf.c b/www/seamonkey2/files/patch-nsprpub-pr-src-io-prprf.c
index 8c48ad1e08fb..f9949d6d9c96 100644
--- a/www/seamonkey2/files/patch-nsprpub-pr-src-io-prprf.c
+++ b/www/seamonkey2/files/patch-nsprpub-pr-src-io-prprf.c
@@ -1,12 +1,14 @@
---- nsprpub/pr/src/io/prprf.c Wed Feb 26 15:53:42 2003
-+++ nsprpub/pr/src/io/prprf.c Thu Oct 16 22:50:40 2003
-@@ -52,5 +52,8 @@
+--- nsprpub/pr/src/io/prprf.c.orig Mon Mar 8 22:18:19 2004
++++ nsprpub/pr/src/io/prprf.c Fri Mar 19 15:26:55 2004
+@@ -51,7 +51,10 @@
+ ** Note: on some platforms va_list is defined as an array,
** and requires array notation.
*/
--#if (defined(LINUX) && defined(__powerpc__)) || \
+-#if (defined(LINUX) && defined(__x86_64__))
+#if defined(__amd64__)
+#include <stdarg.h>
+#define VARARGS_ASSIGN(foo, bar) va_copy((foo), (bar))
-+#elif (defined(LINUX) && defined(__powerpc__)) || \
++#elif (defined(LINUX) && defined(__x86_64__))
+ #define VARARGS_ASSIGN(foo, bar) __va_copy((foo), (bar))
+ #elif (defined(LINUX) && defined(__powerpc__)) || \
(defined(LINUX) && defined(__s390__)) || \
- (defined(LINUX) && defined(__s390x__)) || \
diff --git a/www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in b/www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in
deleted file mode 100644
index f7b62d4df6a2..000000000000
--- a/www/seamonkey2/files/patch-other-licenses_libical_src_libical_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- other-licenses/libical/src/libical/Makefile.in.orig Thu Feb 13 15:50:58 2003
-+++ other-licenses/libical/src/libical/Makefile.in Thu Feb 13 15:51:07 2003
-@@ -179,7 +179,7 @@
- $(PERL) $(ICALSCRIPTS)/mkrestrictiontable.pl -i $(srcdir)/icalrestriction.c.in \
- $(DESIGNDATA)/restrictions.csv > icalrestriction.c
-
--ifneq (,$(filter BeOS Darwin OpenVMS,$(OS_ARCH)))
-+ifneq (,$(filter BeOS Darwin OpenVMS FreeBSD,$(OS_ARCH)))
- DEFINES += -D__USE_BSD=1
- endif
-
diff --git a/www/seamonkey2/files/patch-qt b/www/seamonkey2/files/patch-qt
index 8f1959e47c31..80213cec7548 100644
--- a/www/seamonkey2/files/patch-qt
+++ b/www/seamonkey2/files/patch-qt
@@ -1,15 +1,15 @@
---- configure.orig Thu Feb 12 11:11:29 2004
-+++ configure Wed Feb 25 17:48:17 2004
-@@ -9259,7 +9259,7 @@
+--- configure.orig Mon Mar 15 23:00:47 2004
++++ configure Fri Mar 19 18:09:53 2004
+@@ -9370,7 +9370,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liconv $LIBS"
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 9265 "configure"
+ #line 9376 "configure"
#include "confdefs.h"
-@@ -9290,7 +9290,7 @@
+@@ -9401,7 +9401,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -18,16 +18,16 @@
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for libiconv in -liconv""... $ac_c" 1>&6
-@@ -9300,7 +9300,7 @@
+@@ -9411,7 +9411,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liconv $LIBS"
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 9306 "configure"
+ #line 9417 "configure"
#include "confdefs.h"
-@@ -9331,7 +9331,7 @@
+@@ -9442,7 +9442,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -36,15 +36,54 @@
else
echo "$ac_t""no" 1>&6
fi
-@@ -12047,9 +12047,9 @@
+@@ -12299,9 +12299,9 @@
--MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices spellcheck"
-+MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices spellcheck"
+-MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
++MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
-MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm datetime finger cview layout-debug tasks"
+MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm datetime finger cview layout-debug tasks"
# Check whether --enable-extensions or --disable-extensions was given.
if test "${enable_extensions+set}" = set; then
+@@ -12507,15 +12507,15 @@
+
+
+ if test -z "$GSSAPI_LIBS" ; then
+- LIBS="$LIBS -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
+- echo $ac_n "checking for gss_init_sec_context in -lgssapi_krb5""... $ac_c" 1>&6
+-echo "configure:12513: checking for gss_init_sec_context in -lgssapi_krb5" >&5
+-ac_lib_var=`echo gssapi_krb5'_'gss_init_sec_context | sed 'y%./+-%__p_%'`
++ LIBS="$LIBS -lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi -lcrypt"
++ echo $ac_n "checking for gss_init_sec_context in -lgssapi""... $ac_c" 1>&6
++echo "configure:12513: checking for gss_init_sec_context in -lgssapi" >&5
++ac_lib_var=`echo gssapi'_'gss_init_sec_context | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lgssapi_krb5 $LIBS"
++LIBS="-lgssapi $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 12521 "configure"
+ #include "confdefs.h"
+@@ -12543,7 +12543,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- GSSAPI_LIBS="-L$GSSAPI_DIR/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
++ GSSAPI_LIBS="-L$GSSAPI_DIR/lib -lgssapi -lkrb5 -lasn1 -lroken -lcrypto -lcom_err -lcrypt"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+@@ -12653,7 +12653,7 @@
+ cat > conftest.$ac_ext <<EOF
+ #line 12655 "configure"
+ #include "confdefs.h"
+- #include <gssapi/gssapi.h>
++ #include <gssapi.h>
+ int main() {
+ gss_OID oid = GSS_C_NT_HOSTBASED_SERVICE;
+ ; return 0; }
diff --git a/www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk b/www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk
index 9c79efbaf878..caabfc098e9f 100644
--- a/www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk
+++ b/www/seamonkey2/files/patch-security::coreconf::FreeBSD.mk
@@ -1,5 +1,5 @@
--- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
-+++ security/coreconf/FreeBSD.mk Sun Dec 14 11:38:37 2003
++++ security/coreconf/FreeBSD.mk Fri Mar 19 15:52:59 2004
@@ -35,16 +35,18 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -27,7 +27,7 @@
endif
-MKSHLIB = $(CC) $(DSO_LDOPTS)
-+MKSHLIB = $(CC) $(DSO_LDOPTS) -o $@
++MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
ifdef MAPFILE
# Add LD options to restrict exported symbols to those in the map file
endif
diff --git a/www/seamonkey2/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc b/www/seamonkey2/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
index ed281efd9234..ebe5474ca275 100644
--- a/www/seamonkey2/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
+++ b/www/seamonkey2/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
@@ -1,11 +1,11 @@
---- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Sun Jul 20 11:45:41 2003
-+++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Sun Jul 20 11:49:09 2003
+--- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Tue Mar 16 03:07:25 2004
++++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Fri Mar 19 15:58:14 2004
@@ -8,7 +8,7 @@
* 1 is AddRef
* 2 is Release
*/
-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
+#if !defined(__ia64)
- XPTC_EXPORT NS_IMETHOD Stub3();
- XPTC_EXPORT NS_IMETHOD Stub4();
- XPTC_EXPORT NS_IMETHOD Stub5();
+ NS_IMETHOD Stub3();
+ NS_IMETHOD Stub4();
+ NS_IMETHOD Stub5();